ASA 5505 access to RDP while using client VPN

Posted on 2012-09-09
Last Modified: 2012-09-10

When I connect to my ASA through client VPN, I am unable to connect to a Windows server with RDP.  So, I located the following command:

static (inside,outside) tcp interface 3389 192.168.1.XXX 3389 netmask
And when I enter the command, I receive the following error.

ERROR: This syntax of nat command has been deprecated.
Please refer to "help nat" command for more details.

So, I tried to create a new command with the help command and now I am lost.

The version I am running is
Cisco Adaptive Security Appliance Software Version 8.4(3)

Could someone help me create a new command?

Question by:pzeitham
    LVL 57

    Expert Comment

    by:Pete Long
    LVL 57

    Accepted Solution

    object network Server-3389
      host 192.168.1.XXX
      nat (inside,outside) static interface service tcp 3389 3389
    access-list inbound permit udp any object Server-3389 eq 3389
    access-group inbound in interface outside

    Author Closing Comment

    That worked!

    Thank you for the quick response!!
    LVL 57

    Expert Comment

    by:Pete Long
    No probs glad to help

    Author Comment

    Hello again,

    When I added the mentioned lines, I am able to RDP into the machine I set up the ACL for.  However, that then breaks my ACL I have set up to forward smtp to the server.

    Any ideas?

    For reference, I have attached my config

    Featured Post

    Maximize Your Threat Intelligence Reporting

    Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

    Join & Write a Comment

    Suggested Solutions

    Let’s list some of the technologies that enable smooth teleworking. 
    OfficeMate Freezes on login or does not load after login credentials are input.
    To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
    This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now