Reboot and Select Proper Boot Device

So I have had to reconstruct a disk by copying all of the hard drive contents under linux to another disk and then using a windows repair disk to reconstruct the MBR and BCD.
Sequence I used:
  -Copy Files to partition.
  -Load Recovery Disk and let startup repair fix something.
  -bootrec.exe /fixmbr
  -bootrec.exe /rebuildbcd (after deleting old bcd)
  -DISKPART --> select disk {X} --> select volume {Y} --> active
(where X and Y are the correct disk and volume for my windows drive)
  -Let startup repair correct MBR options

Windows now boots when I select the windows drive from my boot devices manually (press f12 to select boot device at BIOS), however even though the exact same device is at the top of my boot priority in BIOS settings I get the "Reboot and select proper boot device..." error.

That's the really weird part to me - it is the exact same boot device either way (serial number for the HDD ST3....etc, very unique) but when I just let the boot run as normal it doesn't load.

Appreciating any help available,
Andy
PPCRAsked:
Who is Participating?
 
PPCRConnect With a Mentor Author Commented:
[SOLUTION]::
So the RAID drives did indeed have a bootloader installed on them. I was able to boot into linux and use fdisk /dev/sd[x] and toggle the 'a' flag to remove boot capability from the first drive in the array and that solved my problem! Windows now boots normally.
0
 
Norm DickinsonGuruCommented:
Ensure the volume is set to active.
0
 
PPCRAuthor Commented:
As I mentioned in my  outlined sequence, I have used DISKPART to successfully register the windows partition as active.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
Norm DickinsonGuruCommented:
Is there an update to the BIOS firmware available?
0
 
PPCRAuthor Commented:
There is not, this disk was also bootable before I had to pull these shenanigans with copying the file structure over to a new disk. Basically I hard-cloned the drive by reconstructing the mbr/bootloader sequence.
Also, I forgot to mention but I also ran the following command before running bootrec.exe /fixmbr:

bootsec /nt60 SYS /mbr

Open in new window

Which completed successfully on my Windows Drive.
0
 
Frosty555Connect With a Mentor Commented:
Not sure what motherboard you have, but on some motherboards they require that the bootable drive be on SATA1, or in some cases SATA1-4 but NOT SATA5 or SATA6. Usually this is because the last two sata ports are on a different (cheaper) controller than the first four and are intended for CDROM/DVD drives.

Also, do you have any other disks in the system that the motherboard may be erroneously trying to boot from? If so, pull them and try booting without them. The BIOS sometimes lets you configure the first priority boot device is "Hard Drive", but doesn't necessarily let you pick WHICH hard drive, and it automatically chooses the wrong one to boot from, even if the F12 menu allows you to pick a specific disk.
0
 
Norm DickinsonGuruCommented:
I typically use a hard drive cloning adapter that just lets you connect two drives back to back and press a button to clone them, no PC or OS needed. Do you still have the original drive to try that method? It's one step and I have used it dozens of times, even on RAID arrays, without any problems. I have two of these and they work great.
http://www.startech.com/HDD/Duplicators/Portable-eSATA-USB-to-SATA-Standalone-HDD-Hard-Drive-Duplicator-Dock~SATDUPUE
0
 
PPCRAuthor Commented:
I do not still have the original drive, this clone-job was botched due to clonezilla defecting the MBR on the source HDD during a clone operation. I shall keep one of those docks in mind for the future, tqfdotus.

Frosty,
In my case the mobo does permit me to select the specific HDD out of the available. I will attempt removing all the other boot devices and moving it to SATA-1 after a few - there was a problem with the RAID array (disk 1&2, windows is on disk 0) and I am rebuilding that now.
0
 
PPCRAuthor Commented:
So after the raid rebuilt itself I unplugged both of those drives and it boots right up into my windows drive. I saw in the raid message console during BIOS boot that my array is bootable, I checked it with diskpart and it is flagged as "inactive". I believe, however, that there may be a boot sector on the array that is causing this problem - how can I strip the MBR without cleaning out the entire disk?
0
 
David Johnson, CD, MVPOwnerCommented:
would have been nice to have mentioned that it was a raid setup in the beginning
0
 
PPCRAuthor Commented:
Solved with the gooey satisfaction of having stumbled upon the answer with a keen eye and a bit of luck. Not to mention the wise diagnosing tips of Frosty.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.