Problems adding a wireless router behind a Sonicwall TZ-100

We need wireless access in the office.  The manager wanted wanted a separate network for guest wireless. I advised that simply adding a wireless router would easily accomplish this task. There is DHCP on the network as I can attach a guest laptop to the existing network and easily gain network and internet access. We attached a wireless router, configured the WPA security but it just does not seem to work. We can get a wireless conection to the wireless router but we do not get internet access at all.  I did not setup the firewall configuration, so I am not sure what might be the issue yet.

Would we be better off using the X3 or X4 ports for guest wireless?
What could be setup on the firewall that would disallow internet access via a wireless router  attached behind this firewall?
itplatoonAsked:
Who is Participating?
 
Kevin CrossChief Technology OfficerCommented:
Are you certain you are not getting Internet access? I ask because with wireless routers, they often setup their own LAN and DHCP, which works well for folks connecting to wireless but may not route those clients properly through your Internet gateway. In addition, even if routing correctly, if the wireless router is set to DNS and is not properly forwarding requests to your real DNS servers, then you may have Internet access but just not DNS. So try to see if you entered an IP address if you get out? If not, check on the routes.

One option I just used at home is because you already have a firewall, the router is really for access point purposes only; therefore, I set my router in bridge mode. In other words, AP mode only. The DHCP and DNS will be of your main network.

This is easy to configure on most routers. Some even have it simply under DHCP setting. If you tell it to turn off DHCP, it will often just use the existing DHCP server on the network. If you make the WAN IP address a valid IP on your network subnet manually or via DHCP then client of the WAP are on your network also. I hope I explained that clearly enough.

Kevin
0
 
DMTechGrooupCommented:
Are you plugging the network (LAN) cable into the WAN/Internet port or into one of the other LAN (on the Wifi router) ports?

If you use the WAN port, which is fine, then the wifi router has to provide the DHCP address.. if you want the network DHCP to give the address then it needs to be configured for the LAN side and give the router an IP address that does not conflict with anything for the management console.
0
 
itplatoonAuthor Commented:
Yes, I attached the WAN port of the wireless router to the LAN side (10.10.0.xxx) of the firewall. the WAN port then is set for DHCP and gets and IP address from the LAN.  The wireless router is setup for a 192.168.1.xxx subnet.

It seemed like an easy thing to do and works quite easily in my lab environment but on the production LAN, just does not work.
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
DMTechGrooupCommented:
So if I have this right..

The network you are connecting to is 10.10.0.x and is going into the WAN side of the router.  The router pulls a 10.10.0.x IP address as its WAN IP.. then the lan side and the IP address the wifi clients get is 192.168.1.x and the LAN management interface on the wifi is 192.168.1.x?

Do you do any filter or policies on the sonicwall?
0
 
itplatoonAuthor Commented:
The network config you have noted is correct.

The firewall was already setup and running before I got involved. There must be something in place that is interfering.
0
 
DMTechGrooupCommented:
On a soincwall I manage we had to configure the firewall with the MAC address of the wireless device then allow it to have access to the internet.

You can check the Sonicwall Logs to see if it is denying access.. look for the IP address that was assigned to the WAN side of the wifi unit.

Also assign the DHCP on the wifi router your internal DNS or external DNS like googles 8.8.8.8 and 8.8.4.4
0
 
itplatoonAuthor Commented:
Sorry for the late follow up. We were able to get wirelss working.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.