Cannot start or manage offline files - Windows 7

Posted on 2012-09-09
Last Modified: 2016-09-09
Having a very unusual issue
Brand new build - Acer Aspire system. Had Windows Home premium then an Anytime upgrade done to windows 7 professional. Standard applications are installed on this system, nothing too much 'out of the ordinary'
However the issue is that we cannot get the offline files service to start. The service is present, but we cannot start it with the service simply reporting back 'cannot find the file specified'
Log Name:      System
 Source:        Service Control Manager
 Date:          7/09/2012 1:22:36 PM
 Event ID:      7023
 Task Category: None
 Level:         Error
 Keywords:      Classic
 User:          N/A
 Computer:      Laptop50.gpds.local
 The Offline Files service terminated with the following error:
The system cannot find the path specified.
 Event Xml:
 <Event xmlns="">
     <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
     <EventID Qualifiers="49152">7023</EventID>
     <TimeCreated SystemTime="2012-09-07T05:22:36.317090300Z" />
     <Correlation />
     <Execution ProcessID="600" ThreadID="916" />
     <Security />
     <Data Name="param1">Offline Files</Data>
     <Data Name="param2">%%3</Data>

I can confirm that the csc dll file is under %systemroot%\windows\system32 and the csc sys file is present under drivers - however I cannot start the service. I have tried rebuilding the CSC cache but to no avail. SFC / scannow finds no errors and I have tried a dll from a different (known working) machine - though the file version is still reporting the same
This is a 64 bit SP1 install

Starting the service from services.msc does not work - neither does the command line prompts.
Trying to manage offline files from sync center shows all the options as grayed out
Question by:HeronTech
    LVL 1

    Accepted Solution

    I can confirm that local group policy on this machine does not disable offline files either
    LVL 10

    Expert Comment

    "Disable offline files" is even greyed out?
    LVL 1

    Author Comment

    Yes - in the local sync centre the options to enable / disable offline files is grayed out
    LVL 1

    Author Comment

    Screeshots of issue
    LVL 50

    Expert Comment

    HeronTech--The Offline Files service is dependent on the Remote Procedures Call service.  Has that started?

    Your Offline Files cache database may be corrupted.
    LVL 1

    Author Comment

    RPC is started - resetting the offlline cache has already been done, and it wouldnt be corrupted as the service has never been able to start
    LVL 10

    Expert Comment

    I know the anytime upgrade is probably the issue here however I'm lost as to why and can't seem to recreate it on my own.  I find a lot of accounts of others having the same issue after the anytime upgrade.  This may be an exercise in futility but can you tell me a summary of your install process?  Started with 7 home premium, service pack 1 or pre-sp?  All windows updates done and then anytime upgrade was done or was the upgrade done then windows updates downloaded?

    Was this system running home premium for a while or was it a fresh load of home premium, apps, and then upgraded to professional?
    LVL 10

    Expert Comment

    HeronTech, the more I test the more I am starting to lean towards a permissions issue.  Will you try something for me? Your paths may vary but here's what I'm up to.  C:\Windows\CSC, rename or move any folders in that folder.  You may have to give yourself permissions to the folders before you can do so.  Reboot and then attempt to start offline files.  Tell me what happens.
    LVL 1

    Author Closing Comment

    Found out that the default domain policy was disabling group policy - although the local security policy for this machine wasnt. The user was logging on as a local user AFTER they were initially connected to the domain, so the settings still applied.

    Expert Comment

    Got the same issue on Windows 10 Pro, service wouldn't start up. Tried re-initialize the cache per Microsoft -

    Per Microsoft, you can force Windows to clear the cache via a Registry setting.
    1.Open Regedit
    2.Create an entry in HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionNetCache:
     Key Name: FormatDatabase
     Key Type: DWORD
     Key Value: 1
    3.Reboot the PC

    Still not working. Any ideas?

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Free Trending Threat Insights Every Day

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
    Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
    This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.
    The viewer will learn how to back up with the free utility from runtime software, DriveImageXML using Windows 7. Download DriveImageXML from Open folder where it was saved: Start installation by double clicking the install scrip…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    13 Experts available now in Live!

    Get 1:1 Help Now