When InfoPath forms are opened they cause security pop-up

InfoPath Pop-upWe have an InfoPath form on our file server that when opened triggers the pop-up shown below.  What is the easiest way to avoid this?  I've read up a little and have seen code signing mentioned.  Are there any other ways?
jpletcher1Asked:
Who is Participating?
 
rmiconeConnect With a Mentor Commented:
Open up the InfoPath Designer application, go to File -> Options -> Trust Center Settings -> Trusted Locations, and click "Add New Location"

type in the full UNC path to the share
\\server\share

click OK, OK
0
 
Clay FoxDirector of Business IntegrationCommented:
InfoPath uses Internet Explorer's security settings.

If you go in and add the file server as a Trusted Site or Intranet Site in Internet Explorer on a computer than you should not get that.  Make sure the exact URL or UNC path you are publishing the form with and using in the data connections are also in IE as trucsted sites.

If you are not doing code then you should not need a cert, but full trust also eliminates this.
0
 
jpletcher1Author Commented:
Can I just trust our whole file server and use something like \\fileserver\share\* or does it need the path specifically to the file?  Should it be in trusted sites or local intranet sites?
0
 
jpletcher1Author Commented:
Thanks!  Instead of the share name, it wanted us to just enter the server name, such as \\fileserver.  After that, it works great.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.