• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1060
  • Last Modified:

Newly created Exchange Mailbox Database does not show up with Get-MailboxStatistics - Database

I have created a new mailbox database on a different hard disk in an Exchange 2010 environment.  I was able to move two mailboxes to it, inside the Exchange Management console the database shows as mounted and looking at the users list they are both listed in the new mailbox.  Both users are still able to send and receive email fine.  

The problem is that when I run Get-MailboxStatistics - Database "New Database" I get Mailbox database "New Mailbox" doesn't exist as the results.   Is there a problem with the new database and how can I figure out why it is not registering?
0
Blade42
Asked:
Blade42
  • 2
1 Solution
 
AmitIT ArchitectCommented:
Try this way:
Get-Mailbox -Database "YOUR DB NAME" | Get-MailboxStatistics | ft displayname,totaldeleteditemsize,totalitemsize
0
 
Heritage02RiderCommented:
Usually a mailbox does not actually exist until the first item has been received. Try sending a test message to the mailbox and then check.
0
 
Heritage02RiderCommented:
Ignore that last comment... it didn't fully read the message. Sorry!
0
 
Blade42Author Commented:
That works - is there any reason in particular why that works and not the abbreviated?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell┬« is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now