Send Connector for sub-domain

Hello Experts,

Email from our domain to a sub-domain with a separate MX record is failing.  Here's the situation:

- Our domain is example.org and has an MX record pointing to our Exchange server.
- Email sent to a sub-domain, let's call it subdomain.example.org, is failing for internal users.  External email sent to subdomain.example.org is routing fine.
- The DNS server in our environment has a Forward Lookup Zone for example.org that did not previously include an MX record for subdomain.example.org
- All email for both subdomain.example.org and example.org is working fine except for email sent from example.org to subdomain.example.org

I've tried adding an internal DNS record to the Forward Lookup Zone for example.org to include the appropriate MX record for subdomain.example.org and ran a ipconfig /flushdns with no effect.  I can still see email stuck in the Queue Viewer for any email sent to alias@subdomain.example.org with a 451 4.0.0 "DNS query failed" error.

I've also tried creating a Send Connector specifically for the subdomain.example.org domain.  Here's the details:

[PS] C:\Windows\system32>Get-SendConnector subdomain.example.org | fl


AddressSpaces                : {SMTP:subdomain.example.org;1}
AuthenticationCredential     :
Comment                      :
ConnectedDomains             : {}
ConnectionInactivityTimeOut  : 00:10:00
DNSRoutingEnabled            : True
DomainSecureEnabled          : False
Enabled                      : True
ErrorPolicies                : Default
ForceHELO                    : False
Fqdn                         :
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : EXCHANGE
Identity                     : subdomain.example.org
IgnoreSTARTTLS               : False
IsScopedConnector            : False
IsSmtpConnector              : True
LinkedReceiveConnector       :
MaxMessageSize               : 10 MB (10,485,760 bytes)
Name                         : subdomain.example.org
Port                         : 25
ProtocolLoggingLevel         : Verbose
RequireOorg                  : False
RequireTLS                   : False
SmartHostAuthMechanism       : None
SmartHosts                   : {}
SmartHostsString             :
SmtpMaxMessagesPerConnection : 20
SourceIPAddress              : 0.0.0.0
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {EXCHANGE}
TlsAuthLevel                 :
TlsDomain                    :
UseExternalDNSServersEnabled : True

I've specifically enabled the UseExternalDNSServersEnabled property so no internal DNS records will be used and restarted the Microsoft Exchange Transport service multiple times in an attempt to make the Send Connector "stick" with no effect.  What am I doing wrong here?

PS - the only other Send Connector in our environment is assigned the * SMTP address space and is the Default one for all other internet connections.

Thanks in advance.
LVL 2
terminalbAsked:
Who is Participating?
 
terminalbConnect With a Mentor Author Commented:
While I did create an internal MX record previously without any effect, I completely forgot to add the internal A record for the host the MX record pointed to.  Once I did that in the Forward Lookup Zone for the sub-domain in question, mail started flowing again.  Thanks anyway.
0
 
Purple_TidderCommented:
Create a new forward lookup zone for subdomain.example.org and set up MX records within it instead of using example.org.

It may not be the correct way, but it has worked for me.
0
 
terminalbAuthor Commented:
Done - same result.  DNS query failed.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
terminalbAuthor Commented:
This was after an ipconfig /flushdns
0
 
Purple_TidderCommented:
What is your MX record set to?
0
 
Purple_TidderCommented:
Also, I'd think you'd want your external DNS option disabled.  If all the domains are in-house, you'll hit routing issues trying to route internal mail to a public IP or address I would think.
0
 
Purple_TidderCommented:
Thats why I was asking what your MX record was set to.  Glad you got it figured out.
0
 
terminalbAuthor Commented:
No other solutions worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.