[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 891
  • Last Modified:

Should I disable UAC in Windows 7 Ultimate 64-bit or do something else to get rid of multiple blinking shield-icons in notification bar?

Should I disable UAC in Windows 7 Ultimate 64-bit or do something else to get rid of multiple blinking shield-icons in notification bar?

You can see on this screencast that there are three blinking shield-icons in the notification bar on my Windows 7:

http://screencast.com/t/7aIDnIbh

There were many more earlier (perhaps 8), but I clicked on them to close them each after another. The popup text when hovering over these icons says "Password 2.exe is requesting your permission." This is a password application for my two external harddisks. In Windows XP Pro 32-bit, I never had this trouble with multiple blinking shield-icons (because there is no UAC there).

A bit annoying, because they quickly fill up all the notification bar, so I would like to get rid of them somehow. Wonder what the best way to do this is? Disable UAC (if there is no risk with doing this)? Or take some other measures?
0
hermesalpha
Asked:
hermesalpha
  • 2
  • 2
  • 2
  • +4
6 Solutions
 
aadi369Commented:
User Account Control (UAC) is a technology and security infrastructure introduced in Win7. Its is notification pop ups for security purpose.

You can disable UAC if u want rid of it....there is no risk with doing so.

Cheers,

:)
0
 
rindiCommented:
No, No, No!

Don't disable this. There is a very big risk if you disable UAC. It's one of the big improvements over XP and older Windows OS's (it was introduced with Vista, not Windows 7 as stated above). With it on you at least get a notification before something can do harm to OS system files, you can then decide whether the tool you are using or installing is trustworthy or not. Usually when you are installing something and you trust that tool, it is OK to accept it, but sometimes it could be malware that tries to install something, and if you didn't start an installation yourself, your alarm bells should ring and you should then not allow it.

Apart from UAC running, you should also normally use a non-administrative account. That will further help to keep malware off. Apart from that, should someone else have access to your PC he wouldn't be able to harm it because he doesn't know the passwords of the user accounts that have administrative rights.
0
 
Ashok DewanCommented:
When any executable file executes which not known by microsoft operating system then UAC feature ask you "Do you want to run this YES or not". Its mean UAC can protect you if there any exe file execute in background without your interaction then it would display you message "allow or not". this is add on protection. But if you are using good Antivirus suite. then you can disable it , if it is annoying you.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
rindiCommented:
Again, NO! Even "good" antivirus tools aren't perfect, and UAC is an added protection measure for things AV tools can't protect against.

It should only be disabled temporarily if you are experiencing specific problems and when told to do so by professionals.

Get used to the prompt. It is better to have a little inconvenience than having to fix issues later.
0
 
Ashok DewanCommented:
If you are using any Internet security suite with combine feature of host intrusion prevention system then you can disbale it. But I also recommend  its better to keep it enable for extra protection.
0
 
David Johnson, CD, MVPOwnerCommented:
It's your computer you can do what you want. Turning it off will put your computer at risk, if having to give permission to 3 or 4 programs every time you reboot your machine is worth the risk and you like to gamble, fine go right ahead.. Otherwise click the icons and let them continue.. You are advised not to .. but in the end it is your computer.
0
 
Jim-RCommented:
Instead of disabling UAC, use Task Scheduler to create a "task" that will take care of the issue.

For example, I use a search program called "Everything".  There is an option in "Everything's" settings to start it with Windows, but this causes one of those UAC prompts.  To get rid of the prompt, I disabled the option to start the program with Windows inside of Everything and created a "task" that does it automatically using the program's command line option.  On the "General" tab in the properties of the task, you check off the box that is labeled " Run with highest privileges".  This allows the program to start without the annoying prompt because it is basically pre-approving the launch of the program.  Go through the rest of the properties of the task to set up the"triggers" and other settings you want to enable or disable.

I have exported this task from my Task Scheduler.  It is an XML file that I am posting the contents of so you can see what is going on.  The XML file is created automatically by Task Scheduler when you are creating a new task.  This is what it looks like inside the XML file.

<?xml version="1.0" encoding="UTF-16"?>
<Task version="1.2" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
  <RegistrationInfo>
    <Date>2011-07-07T23:21:21.4915136</Date>
    <Author>Jim-PC\Jim</Author>
    <Description>Search Tool</Description>
  </RegistrationInfo>
  <Triggers>
    <LogonTrigger>
      <Enabled>true</Enabled>
      <Delay>PT30S</Delay>
    </LogonTrigger>
  </Triggers>
  <Principals>
    <Principal id="Author">
      <GroupId>S-1-5-32-544</GroupId>
      <RunLevel>HighestAvailable</RunLevel>
    </Principal>
  </Principals>
  <Settings>
    <MultipleInstancesPolicy>StopExisting</MultipleInstancesPolicy>
    <DisallowStartIfOnBatteries>false</DisallowStartIfOnBatteries>
    <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
    <AllowHardTerminate>true</AllowHardTerminate>
    <StartWhenAvailable>true</StartWhenAvailable>
    <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
    <IdleSettings>
      <StopOnIdleEnd>true</StopOnIdleEnd>
      <RestartOnIdle>false</RestartOnIdle>
    </IdleSettings>
    <AllowStartOnDemand>true</AllowStartOnDemand>
    <Enabled>true</Enabled>
    <Hidden>false</Hidden>
    <RunOnlyIfIdle>false</RunOnlyIfIdle>
    <WakeToRun>false</WakeToRun>
    <ExecutionTimeLimit>PT0S</ExecutionTimeLimit>
    <Priority>7</Priority>
    <RestartOnFailure>
      <Interval>PT1M</Interval>
      <Count>3</Count>
    </RestartOnFailure>
  </Settings>
  <Actions Context="Author">
    <Exec>
      <Command>"C:\Program Files (x86)\Everything\Everything.exe"</Command>
      <Arguments>-startup</Arguments>
      <WorkingDirectory>C:\Program Files (x86)\Everything\</WorkingDirectory>
    </Exec>
  </Actions>
</Task>

Open in new window

Note line 17.  This is the setting that allows the program to run without creating the annoying prompt.  Line 46 shows the "arguments" or command line option (in this case -startup) for the program that is automatically entered by Task Scheduler to start up the program minimized in the task bar icon area.  Without it, the program just launches in front of you as if you had started it from a shortcut.

More information on how to use this useful tool can be found at the following link:

Schedule A Task
0
 
McKnifeCommented:
Yes, I join Jim-R. Instead of debating over UAC, we should have a look at the "blinking icons" to see what it actually is. Sometimes it is not even needed and can be prevented from starting using msconfig.exe ->startup items.
If needed, create a scheduled task instead, using your user as executioner and set the trigger to run at logon and check the box named "run with highest privileges". Afterwards, you can disable the original startup item.

Done. No UAC change needed.
0
 
hermesalphaAuthor Commented:
Thanks everyone! The Task Scheduler seems to be very useful. Can keep UAC then if I use Task Scheduler as Jim-R described in detail. One problem I just found out is that Password.exe adds itself to msconfig Startup, even after I uncheck it in msconfig. Perhaps I can come to terms with this using Task Scheduler. Now I also disconnect the two 250 GB external HDD:s before booting up (took extremely long time to boot when I had them connected during bootup). But even then, Password.exe adds itself to msconfig.
0
 
Jim-RCommented:
What program is "Password.exe"?  Where did this program come from?  There may be a way to keep it from re adding itself to "mscofig" by accessing an option or using some command line option of the program.  I would need to know more about the program to research any possible solution to this.

If this is a "Freecom Toughdrive" You can possibly have the password feature removed.  See this link from their support site.  
0
 
McKnifeCommented:
I suggest you configure another scheduled task that runs at shutdown that deletes the registry entry / autostart entry of password.exe (msconfig will tell you what path).
So either use reg /delete <key> /f
if it's a registry entry or use del /q
The task has to run elevated, again ->check the box named "run with highest privileges".
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
  • 2
  • 2
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now