Bad NFS Permissions on a Share - CentOS 6.2

Posted on 2012-09-11
Last Modified: 2012-09-12
I created an NFS share on CentOS 6.2 and for the most part it works great. I share a file out from ServerA to ServerB and I can view them on both. The only problem is that on ServerB, the permissions are screwed up and the file is read-only, even if I create the file on ServerB. Here is what I see when I run ls -al on the share:

-rw-r--r--.  1 4294967294 4294967294    7 Sep 11 07:41 test2.txt
-rw-r--r--.  1 4294967294 4294967294    7 Sep 11 07:56 test3.txt
-rw-r--r--.  1 4294967294 4294967294    7 Sep 11 07:49 test.html

-rw-r--r--.  1 nfsnobody nfsnobody    7 Sep 11 07:41 test2.txt
-rw-r--r--.  1 nfsnobody nfsnobody    7 Sep 11 07:56 test3.txt
-rw-r--r--.  1 nfsnobody nfsnobody    7 Sep 11 07:49 test.html

Any help is greatly appreciated!

Also - my etc/exports file shows "/var/share *(rw,sync,all_squash)" and I restarted NFS service afterwards.
Question by:brendan-amex
    LVL 3

    Accepted Solution

    If you're mounting out of /etc/fstab, do they differ between servers? Are they both 32-bit, 64-bit, or mixed? It looks like nfsnobody is UID 2^32-2 on server A, but not on server B. So, you have some options:

    Use a mount option to translate UID 2^32-2 to your user
    Synchronize the UID/GIDs between the two systems
    Set a umask such that created files get less restrictive permissions than 644

    Author Comment

    Thank you for your post. So I got the permissions to look correct with changing the Domain in the config file /etc/idmapd.conf, but I still get permission denied when trying to edit a file on ServerA that was created on ServerB. Am I not supossed to be able to edit any files inside the share on a different server?
    LVL 3

    Expert Comment

    It really does depend on the settings. What does


    Open in new window

    show on each server?

    Author Comment

    Mount on Server that's shared out:
    (nothing regarding the share)

    Mount on client server:
    server.domain:/var/shared on /var/shared type nfs (rw,hard,vers=4,addr=,clientaddr=

    Author Comment

    Nothing needs to be mounted from the server to the client, right? Only the client to the server?

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    6 Surprising Benefits of Threat Intelligence

    All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

    Attention: This article will no longer be maintained. If you have any questions, please feel free to mail me. Please see for the updated article. It is avail…
    FreeBSD on EC2 FreeBSD ( is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
    Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    9 Experts available now in Live!

    Get 1:1 Help Now