Animation not working in Oracle APEX 4.1.0.00.32 Dial/Gauge Chart

Hi - I am trying to get a gauge chart in Oracle APEX to animate, but I can't get it to work.  Below is the custom XML.  The chart displays correctly, but there is no animation.  Can anyone see what I'm missing? Thx!

<?xml version = "1.0" encoding="utf-8" standalone = "yes"?>
<anychart>
  <settings>
    <no_data show_waiting_animation="False">
      <label>
        <text>#NO_DATA_MESSAGE#</text>
        <font family="Verdana" bold="yes" size="10"/>
      </label>
    </no_data>
  </settings>
  <margin left="0" top="0" right="0" bottom="0" />
  <gauges>
    <gauge>
      <chart_settings>
        <title text_align="Center" position="Top" >
          <text>Pipe</text>
          <font family="Arial" size="14" color="0xBC0001" />
        </title>
        <chart_background>
          <fill type="Solid" color="0xffffff" opacity="0" />
          <border enabled="false"/>
          <corners type="Square"/>
        </chart_background>
        <data_plot_background></data_plot_background>
      </chart_settings>
      <circular>
        <axis start_angle="90" sweep_angle="180" >#SCALE_DATA#
          <scale_bar>
            <fill type="Solid" color="0xBC0001" />
          </scale_bar>
          <major_tickmark enabled="true" length="10" />
          <minor_tickmark enabled="false" />
          <labels enabled="true" align="Inside" text_align="Near" rotation="0" >
            <format>
              <![CDATA[{%Value}{numDecimals:0,decimalSeparator:.,thousandsSeparator:\,}]]>
            </format>
            <font family="Arial" size="8" color="#000000" />
          </labels>
        </axis>

          <pointers>

            #DATA#

              <tooltip enabled="false"/>
              <animation enabled="True" start_time="0" duration="4" interpolation_type="Bounce" />
              <label enabled="true" align="Outside" text_align="Near" >
                <format>
                  <![CDATA[{%Value}{numDecimals:0,decimalSeparator:.,thousandsSeparator:\,}]]>
                </format>
                <font family="Arial" size="12" color="0xBC0001" />
                <position anchor="CenterTop" />
              </label>
</pointer>
          </pointers>

        <frame type="Auto" />
      </circular>
    </gauge>
  </gauges>
</anychart>

Open in new window

sjsimpson2000Asked:
Who is Participating?
 
gatorvipCommented:
I'm not very familiar with the AnyChart items, but this example shows an additional setting that I don't see in your XML code.

  <settings>
 	    <animation enabled="true" />
  </settings>

Open in new window

0
 
sjsimpson2000Author Commented:
So obvious....  THANK YOU!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.