MS SQL SERVER maximum connections (3) has already been reached

On 9/7, our SQL Server Express Database started to report Event ID 17809 "Maximum number of connection (3) has already been reached" .   As far as I know, no changes were made to the database/server.   The last windows updates were installed on 7/19.  The server was rebooted on 7/26 and then not until 9/6.
We ran the SP_Configure query:
sp_configure 'show advanced options', 1
go
reconfigure
go
sp_configure 'user connections', 0
go

If I look in the SQL Server Connection properties, Maximum Num of Server Connections = 0
and Allow Remote Connections is checked and query timeout = 0

Thanks for any help!  -j
juliAsked:
Who is Participating?
 
AnujSQL Server DBACommented:
Glad that it is solved, please mark my post as answer if that helps you.
0
 
AnujSQL Server DBACommented:
Did you done the following?

sp_configure 'user connections', 0
GO
RECONFIGURE WITH OVERRIDE
GO
0
 
juliAuthor Commented:
I didn't but I will.   Stay tuned...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
juliAuthor Commented:
This is the message after running the above query:  
Configuration option 'user connections' changed from 0 to 0. Run the RECONFIGURE statement to install.
0
 
AnujSQL Server DBACommented:
Did you run RECONFIGURE WITH OVERRIDE after that?
0
 
juliAuthor Commented:
The first time I ran the query as you wrote it (both at the same time).    I ran them seperately and the RECONFIGURE WITH OVERRIDE said that it completed successfully.
However, I'm still having the problem with the 3 connection limit.  If I try to do anything else in SQL Mgmt Studio (open another New Query, for example) it will disconnect my session and I'll see the error in the Event Viewer.
I have not rebooted the server since running any of these database queries.  It didn't seem necessary but am open to any suggetions.
0
 
AnujSQL Server DBACommented:
If you change this configuration, You should restart the SQL Server Service to take effect, this is what MSDN says here.
0
 
juliAuthor Commented:
Restarting the service might have done the trick (I should have considered that before...)
I need to see what happens when several people are working with the database application but my initial testing looks promising.    Thanks for your prompt replies and suggetions.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.