MRTG cfgmaker - generating cfg file correctly

hi guys,

I am trying to install mrtg on ubuntu for monitoring traffic coming on our router

and when i run the command indexmaker --output=/var/www/mrtg/index.html /etc/mrtg/mrtg.cfg

i get the following error

Error: did not find any matching data in cfg file

here is whats is in the cfg file

(i have attached)
photo.JPG
jonathanduane2010Asked:
Who is Participating?
 
giltjrConnect With a Mentor Commented:
See the part that start off with: "Warning: skipping public@217.115.123.23".

That means that for some reason the host you are running the cfgmaker command on can not communicate to 217.115.123.23 using SNMP.  From a few before that warning you can see that it was attempting to use SNMP V1.

First basic things to check:

Verify that SNMP is running on 217.115.123.23 and that it is allowing SNMPV1 queries.  If it does  not allow SNMPV1, try using cfgmaker and specifying SNMPV2.  You need to use the option "--snmp-options=:::::2".  See http://www.linuxhomenetworking.com/wiki/index.php/Quick_HOWTO_:_Ch22_:_Monitoring_Server_Performance for more info.

Verify that any/all firewalls allow UDP port 161 to flow bi-directionally between your host and 217.115.123.23.
0
 
nociSoftware EngineerCommented:
does the cfg file reflect your hardware to be monitorred? [ id. are you requesting exiting data]
Do you have the snmp autorisations to request that data?

Those are the most likely causes...  

It might already been wrong with cfgmaker, cfgmaker should have told you which graphs it added. If it didn't tell you, most probable cause is authorizations.
0
 
giltjrCommented:
Is that all that in the cfg file?  It looks a little empty to me.

Did the cfgmaker command run correctly?  To me it looks almost as if you ran it, but if failed due to an error, say like the wrong community string or some other issue trying to talk to the IP address you have listed.
0
Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

 
jonathanduane2010Author Commented:
really?? Can you run it on all interfaces??

the community string is just public?

maybe its a rights issue??
0
 
jonathanduane2010Author Commented:
if it is an authorisation issue, what is the best way to check??
0
 
giltjrCommented:
When you ran the cfgmaker command what messages did you get back?

Can you post the whole config file that you are trying to run indexmaker against?
0
 
jonathanduane2010Author Commented:
i get this error back

Error: did not find any matching data in cfg file

and i have attached the cfg file in my first post?
0
 
giltjrCommented:
The message "Error: did not find any matching data in cfg file" is from the indexmaker command.  We need to see the messages from the cfgmaker command

You attached a screen shot of a the config file, not the actual file.

If that is the full config file, then the cfgmaker command did not work and created "null/empty" config file.  indexmaker will fail and generate the message you received when run against a null/empty file.
0
 
jonathanduane2010Author Commented:
my snmpd.conf  just has

rocummunity public
0
 
jonathanduane2010Author Commented:
ah ok...

I will run that now,.....
0
 
jonathanduane2010Author Commented:
ok here is the error i get when i run the cfgmaker
configerror.JPG
0
 
jonathanduane2010Author Commented:
217.115.123.23 is the address of the machine i am trying to run the cfgmaker command on.

can i disable the firewall and test it, and if so how??
0
 
giltjrCommented:
I can't tell you how, as I have no clue to many things I would need to know in order to do it.

Such as,

Is there a firewall (or more than one) between your host and 217.115.123.23?
Is there a firewall running on your host?
Is there a firewall running on 217.115.123.23?
What types of systems and firewalls are they?
What bad things may happen if you disable the firewall, such as services that are hosted on 217.115.123.23 may stop working or a unauthorized person could gain access to 217.115.123.23.
0
 
jonathanduane2010Author Commented:
ok i have disabled the firewall, can i run the cfgmaker on eth1 or eth2?? if i wanted to monitor all traffic coming in and out of the network cards of the machine?

the background is that

i have a linux machine acting as a router with two network cards

one being 217.115.123.23

and its this machine that i am trying to install and configure mrtg
0
 
nociSoftware EngineerCommented:
why not logon to 217.115.123.23
and run cfgmaker on localhost...
and publish the results using a webserver based on the output of indexmaker..?

no special fiddling needed with firewalls...
0
 
jonathanduane2010Author Commented:
log on to it how?? i am loggged into it, i have the machine here in front of me??
0
 
nociSoftware EngineerCommented:
The use of an Public IP implies a remote server in the current NAT riddled internet.
A lot of problems are prevented if the localhost address is used because no firewalls are crossed this way. (use of address 127.0.0.1 & interface lo0 are taken care of in host based firewalls as most systems can trust connections from itself.).

Also many server implementation have more trust in access from localhost.

With logging on i mean getting access to the command line on the system itself, if you can access the console then use that, use ssh otherwise.

If the cfgmake fails with error along being unable to access public@localhost you need to verify the snmp server setup. (configuration for snmp most probably is in /etc/snmp/snmpd.conf )
0
 
giltjrCommented:
Can you run cfgmaker against the "inside" IP address?  The non-public one?
0
All Courses

From novice to tech pro — start learning today.