?
Solved

Epson Receipt Printer T88IV with serial to usb

Posted on 2012-09-12
8
Medium Priority
?
7,666 Views
Last Modified: 2012-09-16
I am having trouble getting an epson receipt printer to work on windows xp.  I know these thermal printers can be finicky.    The printer  has a serial output  with a belkin serial to usb adapter.  

If I create a generic text printer, I can at least print.  But trying to install the advanced printer driver 4, I get either, "user intervention required" or "not ready".  Each time I have tried a different port or driver, I have uninstalled the previous driver through add/remove programs.    

Unfortunately, this computer does not have a regula serial port.   I have another computer which I can't use for production that does have a serial port and when I take off the belkin, it works fine.  

I have downloaded the belkin drivers and the epson usb driver.  I have tried to set the printer up as serial, parallel and usb.  I am pretty sure it is supposed to be serial.  

I'm ready to just use the generic printer.  I would like to figure this out though.  Any insight would be appreciated.
0
Comment
Question by:Scott Fell,  EE MVE
  • 4
  • 3
8 Comments
 
LVL 30

Expert Comment

by:flubbster
ID: 38391881
Open device manager and expand the Ports entry.
Find the USB to Serial entry
Double-click the entry to open it's properties
Look at the current settings. Make sure that the settings match the default settings of the printer, as determined by the dip switches. This includes the Baud Rate.

The printer, in default mode, is set as follows:

Handshake: DTR/DSR
Bit Length: 8 Bits
Parity Check : No
Parity Selection: Odd
Baud Rate: 38400
0
 
LVL 30

Expert Comment

by:flubbster
ID: 38391925
btw...what kind of cable are you using?

9 to 9 pin?
9 to 25 pin?
0
 
LVL 54

Author Comment

by:Scott Fell, EE MVE
ID: 38391979
To your first part I have done that.  Actually the printer is set to parity none and baud rate 9600.   It is a 9 to 25 where the 25 is at the printer.

I think it might need a virtual port?  I have never set that up.  From reading other posts, it I have un installed the drivers.  Restarted then with the printer not attached, installed the drivers.  I have drivers for the printer, drivers for the usb converter and drivers for the usb and the printer.   I have the drivers from https://www.epsonexpert.com/login.  I have tried both the most current driver and I 4.03 from 2009 for the printer driver.  

I did figure out that each time I wanted to try a different driver configuration I had to uninstall completely, install the driver, then restart again.  The problem is the port is set to com1.   When I look at the device mgr under Ports, I have the Belkin on USB (com5), communications port (com1), ecp printer port (lpt1) and Epson Com Emulation USB port (com2).

When I go to the printers and fax's area and change the port, nothing happens unless I am using the generic printer.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 30

Accepted Solution

by:
flubbster earned 2000 total points
ID: 38392064
If you haven't already, take a look at this page:

http://www.beaglehardware.com/howtoserial.html

Also verify that the 9 to 25 pin cable matches the wiring diagram as shown.
0
 
LVL 63

Expert Comment

by:☠ MASQ ☠
ID: 38392150
Is there capacity to add a serial port on a PCI board?
It's likely the Belkin adaptor isn't fully supporting bi-directional printing functions so some messages get lost.
0
 
LVL 54

Author Comment

by:Scott Fell, EE MVE
ID: 38392172
Thanks. I have been to that page a bunch of times already.    The cable is pre wired and has the numbers 2901-6mf9 and googleing that shows it to be a null modem serial cable which is what tech support at epson said.   However, Epson tech support does not support the usb conversion add on so I couldn't get to far with them.

I have been at this for a couple of days.  I'm wondering if it just is not meant to be.  Like I said, it works fine on another windows xp when I just use the cable without the usb conversion.   And it works when with the usb when I make a generic printer.    Is there any advantage I get in using the epson driver vs the generic?
0
 
LVL 30

Expert Comment

by:flubbster
ID: 38392211
The only things I can think of is possibly advanced formatting capabilities. Other than that, I guess you would have to simply test it to ensure it does what you need it to do.
0
 
LVL 54

Author Closing Comment

by:Scott Fell, EE MVE
ID: 38403535
That was kind of the answer.   I think the real issue is using the serial to usb converter.    For the advanced driver, I downgraded to version 3 from 4 and that did some of the trick.   I am using escp/p codes to print now so the apd is not needed.  

Thank you for your help!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
This tutorial is intended to teach the basics of 3-D Modeling using TinkerCad.com as the Computer Aided Drafting software. Once complete this model can be 3D printed.
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …

612 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question