?
Solved

Shared Mailbox Calendar Sharing

Posted on 2012-09-12
13
Medium Priority
?
2,027 Views
Last Modified: 2012-09-14
Hello experts!

This should be an easy one, but I'm stumped. We are currently running Exchange 2010 SP2. I have created a shared mailbox via powershell, added it to the correct ABP, and set the full access / send as permissions appropriately. However, when a user with full access attempts to share the calendar on this multi user account,  the option is greyed out. I cannot figure this out!

I've even created a normal account (non shared mailbox, simply a "user mailbox") and attempted to give the same full access permission. Testing shows the same thing occurs - the option for sharing the calendar is greyed out...

I feel like I'm missing something really simple, it's frustrating!

I'll leave this webpage up and check back frequently for any questions you may have.

Thank you!
0
Comment
Question by:jmichaelpalermo4
  • 6
  • 5
  • 2
13 Comments
 
LVL 23

Expert Comment

by:Stelian Stan
ID: 38391986
Check the permissions by:
Get-MailboxFolderPermission -identity “Name of the shared mailbox:\Calendar”
0
 
LVL 23

Expert Comment

by:Stelian Stan
ID: 38391998
0
 
LVL 3

Author Comment

by:jmichaelpalermo4
ID: 38392002
Unfortunately, my powershell knowledge is quite limited... here's the results of the command:


RunspaceId   : dd638cb7-dfd0-4c85-b989-808df58bf829
FolderName   : Calendar
User         : Default
AccessRights : {AvailabilityOnly}
Identity     : Default
IsValid      : True

RunspaceId   : dd638cb7-dfd0-4c85-b989-808df58bf829
FolderName   : Calendar
User         : Anonymous
AccessRights : {None}
Identity     : Anonymous
IsValid      : True

It looks to me like the users I've added with full access are not showing up
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 23

Assisted Solution

by:Stelian Stan
Stelian Stan earned 1000 total points
ID: 38392028
To give permissions to those users you have to use this commands:

Set-MailboxFolderPermission -Identity “Name of the shared mailbox:\Calendar” -User UsertoGetRights -AccessRights Editor

Add-MailboxFolderPermission -Identity “Name of the shared mailbox:\Calendar” -User UsertoGetRights -AccessRights Editor

For more details:http://www.edugeek.net/blogs/thescarfedone/1169-exchange-2010-granting-write-permission-calendar-sharing-owa-2010.html
0
 
LVL 23

Expert Comment

by:Stelian Stan
ID: 38392039
0
 
LVL 3

Author Comment

by:jmichaelpalermo4
ID: 38392107
Ran the: Set-MailboxFolderPermission -Identity “MyCalendar:\Calendar” -User myuser@mydomain.com -AccessRights Editor

RunspaceId   : dd638cb7-dfd0-4c85-b989-808df58bf829
FolderName   : Calendar
User         : myuser
AccessRights : {Editor}
Identity     : myuser
IsValid      : True


Everything looked great! Ran successfully and everything. However, I logged into "myuser" and found the share command was still greyed out. I read through the articles and they do not seem to account for this.. :(
0
 
LVL 3

Author Comment

by:jmichaelpalermo4
ID: 38392124
Also, I check the permission on "MyCalendar" in OWA and it shows Editor! Arg!
0
 
LVL 3

Author Comment

by:jmichaelpalermo4
ID: 38392166
Thank you for all your help, by the way, I feel very close to a solution... I'm just missing something
0
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38392254
So your saying your trying to share your calendar or the shared ?
What OL profile are you logged into ?
What is the version of OL and if you could please share a screenshot :)

- Rancy
0
 
LVL 23

Expert Comment

by:Stelian Stan
ID: 38392328
0
 
LVL 3

Author Comment

by:jmichaelpalermo4
ID: 38395718
Sorry for the delay in my response. I was trying to do some PS commands and really screwed up the server yesterday! Anyway, I'm using Outlook 2010. I am trying to share the shared calendar, not my own.

As for a screenshot, I'm not really sure what you want there. When you right click the calendar and select share, all the options are greyed out :(
0
 
LVL 52

Accepted Solution

by:
Manpreet SIngh Khatra earned 1000 total points
ID: 38396195
You cant share a another users calendar from your Outlook Profile :(

So simple create a Outlook profile for the Shared Mailbox and share its calendar :)

- Rancy
0
 
LVL 3

Author Comment

by:jmichaelpalermo4
ID: 38399881
Arg! Thanks for all the help fellas. Didn't know this was the case... :(
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Take a look at these 6 Outlook Email management tools which can augment the working and performance of Microsoft Outlook to give you a more rewarding emailing experience.
Steps to fix error: “Couldn’t mount the database that you specified. Specified database: HU-DB; Error code: An Active Manager operation fail”
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
Suggested Courses
Course of the Month16 days, 1 hour left to enroll

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question