Windows 7 Limited Connectivity

I have a Windows 7 64 bit system.  I can obtain an IP address via the LAN port and Wifi - but the system is reporting limited connectivity.  The router is assigning an ip of 192.168.x.x with the gateway and dns.  I can ping the assigned IP address.  But I cannot ping the Gateway.  I've swapped out wi-fi adapters thinking that was the issue.  I've connected cat5e to the onboard nic that did not work.  I'm thinking a recent update has happened, but there is no restore point in the system, so I can't go back.  the system was working yesterday no issue.  According to the updates - MS office updates 2010 and 4 Windows 7 updates.  Other pc's can connect to the router.

Any advice on how to resolve this is appreciated.
Scott HuffmanAsked:
Who is Participating?
 
Scott HuffmanAuthor Commented:
Well it's software and it's McAfee virus/firewall software that caused the issue.  There must have been an update on the program.  I uninstalled the program and it resolved the issue.  I can surf.
Thanks for those that offered suggestions.
0
 
arnoldCommented:
The limited connectivity in windows 7 will be displayed when Internet is inaccessible.

The issue with inability to ping the gateway is such a cognition.
1 possible cause is that the default gateway that is being pushed to the DHCP client is not the right one. I.e. the routers IP was altered, while the DHCP server default gateway option is left to send out the 192.168.x.1.
2 the connection falls onto a vlan, configuration that is not allowed to access the Internet.
0
 
djsharmaTechnical ConsultantCommented:
First you restore you system.Please refer the below link
http://support.microsoft.com/kb/971760.

Check in command prompt that you system is getting gateway IP.If not then Your Default Gateway (the Router) is not listed in your Ipconfig log. Go to Start/Run and type inetcpl.cpl and press enter/Connections/LAN Settings. Make sure all the boxes are unchecked. Now go to Start/Run and type ncpa.cpl and press enter. Right click the Local Area connection/Properties scroll down to Internet Protocol (TCP-IP)/Properties. Make sure Obtain an IP Address and DNS Server Addresws Automatically are both checked. Now go to Start/Run and type CMD. IN the Command Prompt type ipconfig /release and press enter. the IP Address changes to 0.0.0.0 Now type ipconfig /flushdns and press enter. Now type ipconfig /renew. Now type ipconfig /all. You should have a new IP address, and a Default Gateway IP Address. If not there is a disconnect between the router and the computer. Log into the Router setup and make sure DHCP is enabled.
0
 
Scott HuffmanAuthor Commented:
The issue was software not hard-ware.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.