CentOS 5 system boot failure - boots to shell.... HELP

Say,
The system has been working fine.
It now boots to this point

EFI Shell version 1.10 [8192.1]
Device mapping table
Shell>

Server is
NEC SI 1310 Server
Has 3 hard disks with Adaptec Raid controller

How can I diagnose please?
shaunwinginAsked:
Who is Participating?
 
MysidiaConnect With a Mentor Commented:
I recommend getting into the boot configuration of your RAID controller and verifying the health and configuration of the array.

What you are getting suggests that the controller has become non-bootable;
possibly due to a failure of the array or an issue with the RAID controller card.

Also try entering the "map" command at the EFI shell you have right now,
and seeing if any block devices at all are listed;  even CDROM devices should show up in device mapping table....


Getting an EFI shell instead of an OS booting, and no devices listed with  the
device mapping table, as you seemed to suggest, would indicate that the boot configuration is apparently broken,  because the server can't see any storage volumes or devices available....
0
 
arnoldCommented:
What was updated last, kernel?
Can you use centos liveCD to check the boot loader.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
shaunwinginAuthor Commented:
1. Nothing was updated.
0
 
shaunwinginAuthor Commented:
I've noticed the system freezes unexpectedly in the EFI shell. Do you think this is hardware?
There is an adaptec 3405 Raid card. It reports 3 drives optimal and no errors. Could this card be giving an issue perhaps?
0
 
shaunwinginAuthor Commented:
The complete Adaptec RAID specs

Model nr AIC – 9405W
 
Bottom : ASR – 3405 / 128 Mb
 
TCA – 00288 – 01 – B
 
C0731
0
 
shaunwinginAuthor Commented:
The LIVE CD is v big to download... any other suggestions?
0
 
Sikhumbuzo NtsadaSenior IT TechnicianCommented:
You will need some CD/DVD to perform a rescue. So I think "arnold's" comment is crucial going forward.
0
 
arnoldCommented:
Do you still have the cd/DVD you used to install the system? You can use that.
The efi shell might mean there is no menu for what/how to boot the system.
0
 
shaunwinginAuthor Commented:
Say, I've booted with a boot CD and can't see the SCSI Raid hard disk even though the RAID shows array optimal.
Should I run the Adaptec Array utility and Verify the disk?
0
 
shaunwinginAuthor Commented:
I believe the issue is around the raid drive not being detected by BIOS and the EFI shell may need a command or two run in it?
0
 
shaunwinginAuthor Commented:
The device mapping shows only the DVD drive. This is most strange as the Adaptec Raid reports raid is optimal
0
 
rindiConnect With a Mentor Commented:
I agree with the above that probably something happened to your boot configuration. Also the reason you can't see the drives when you boot to the CentOS CD is likely because CentOS 5 isn't the most modern OS and therefore the booting CD probably doesn't include the kernel modules to for the RAID controller you are using. With Red-Hat (CentOS) you often have to add the driver modules yourself from the manufacturer. Probably if you boot using a more current OS/CD it'll be likely that you can then access the file-systems more easily and try repairing the issue (if it is repairable).

I suggest you try either the CentOS 6.3 CD or, easier to use and a smaller download, the PartedMagic LiveCD:

http://partedmagic.com
0
 
shaunwinginAuthor Commented:
RAID card was overheating - blew it cool with air blower and all solved.... Tx 4 info
0
 
MysidiaCommented:
RAID card overheating is decisively a RAID card failure..  although this may be caused by improper cooling within the chassis, blockage of air inlets,  or an unusually high ambient temperature.
If you haven't made permanent repairs to the cooling,  you may need to.


Blowing off a card once with an air blower sounds like a temporary fix.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.