Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

No free\busy information and Automatic replies - Exchange 2010

Posted on 2012-09-13
5
Medium Priority
?
640 Views
Last Modified: 2013-06-18
Hi Exchange Experts

I have the following issue and really need some expert advise please..

Problem:
All Outlook 2007 + 2010 clients cannot view free\busy scheduling when booking meetings – No free\busy information could be retrieved. Your server location could not be determined.
All Outlook 2007 + 2010 Clients cannot set Automatic reply – Your Out of Office settings cannot be displayed, because the server is currently unavailable.

Environment:
Microsoft Exchange 2010
Version - 14.02.0247.005  
Microsoft Exchange 2010 SP2 rollup 4

Workaround:
Automatic replies and free\busy scheduling works through OWA for all clients, but this cannot continue this way.

Could you please advise.
0
Comment
Question by:Gazza007
  • 2
  • 2
5 Comments
 
LVL 35

Expert Comment

by:Bembi
ID: 38396652
You may CTRL - right click the Outlook tray icon and select  Connection status.
Check if there are issues...

Have a look at your OAB (Organisation - Mailbox), where the OAB is published.
Outllok 2003 SP2 and later can use http, older ones need public folders. If public folders are enabled, but not accessable, you get issues on the client.
If  Web based enabled, check if the links under
Server - Client Access  - OAB, if the links are correct there and reachable
Make sure the link, outlook uses is interpreted as "Intranet". You can not access the link via a browser (acces denied), but you can see, if IE shows "Intranet" or "Internet".
If the link is interpreted as "Internet", you may have a proxy issue.
0
 

Author Comment

by:Gazza007
ID: 38397682
Thanks, this is what I've checked thus far.

Ran Get-WebServicesVirtualDirectory | fl   on EXCH Server 1 to verify and confirm output with “Test E-mail Auto-Configuration” from Outlook
Verified the Availability Service of OOF and OAB Urls – Public Url is http://Company
Ran the Microsoft Remote Connectivity Analyser on EXCH Server 1: https://www.testexchnageconnectivity.com/ - Web Services test for Synchronisation, Notification, Availability and Automatic replies OOF
Status: Some Connectivity Tests Failed
Ran the Microsoft Remote Connectivity Analyser on EXCH Server 2: https://www.testexchnageconnectivity.com/ - Outlook connectivity test for Outlook AutoDiscover
Status: Failed
Received AutoDiscover service errors on both connectivity tests.
Ran Get-AutoDiscoverVirtualDirectory | fl   on EXCH Server 1 to verify if availability info and check if autodiscover has been configured correctly
InternalUrl  on EXCH Server 1 is displayed but no ExternaUrl
InternalUrl +ExternalUrl for EXCH Server 1 missing
InternalUrl +ExternalUrl for EXCH Server 2 missing
Checking DNS checks from external - Unknown can't find autodiscover - Non existant domain
I can see that the certificate used for Exchange Outlook Web Access/App is a self signed certificate and has no common name. A SAN cert is required with the common name
These tests were done from the external network/public internet.

Hope this helps so far..
0
 
LVL 37

Accepted Solution

by:
Jamie McKillop earned 1500 total points
ID: 38398529
Hello,

Your first problem is that you cannot use a self-signed certificate with Outlook Anywhere. You need to purchase a SAN certificate with the following names

mail.company.com
autodiscover.company.com
internal name of CAS array

JJ
0
 
LVL 35

Expert Comment

by:Bembi
ID: 38398613
First at all, you need...
DNS setting internal
usually a CNAME record autodiscover --> internal exchange server.
alternatively a A Record with name "autodiscover" and the IP of the exchange

DNS setting external (has to be set at your internet provider)
usually realized by a subdomain and user defined IP address
register there under your ext_domain.tld the subdomain
"yourexternalserver" and point the IP to your external IP address

additionally you may register
"autodiscover" and point the IP to your external IP address

Exchange Management Console - Server - CAS
Use "Configure External Client Access Domains... the result should look like

OWA
internal: https://yourinternalserver.int_domain.tld/owa
external: https://yourexternalserver.ext_domain.tld/owa
ECP
internal: https://yourinternalserver.int_domain.tld/ecp
external: https://yourexternalserver.ext_domain.tld/ecp
ActiveSync
internal: https://yourinternalserver.int_domain.tld/Microsoft-Server-ActiveSync
external: https://yourexternalserver.ext_domain.tld/Microsoft-Server-ActiveSync
OAB
internal: https://yourinternalserver.int_domain.tld/OAB
external: https://yourexternalserver.ext_domain.tld/OAB

Outlook AnyWhere
yourexternalserver.ext_domain.tld

The gateway (firewall to the external world) has to setup as reverse proxy with link translation configured with all external names. So https://yourinternalserver.int_domain.tld/owa has to be translated to
https://yourexternalserver.ext_domain.tld/owa

Microsoft TMG makes everything automatically, all other firewalls have to translate:

Translations for OWA:
/owa
/ecp
/public for public folders
/Exchange for older clients

Translations for Active Sync
/Microsoft-Server-ActiveSync

Translations for Outlook AnyWhere
/rpc
/OAB
/EWS
/autodiscover

https://www.testexchnageconnectivity.com/  can not run successfully, if external names are not configured correctly and external DNS names are not set. This tools test the external accessibility. To test internal autodiscover, --> CRTL - Outlook tray icon -- Test E-Mail AutoConfiguration.
 
Within the certificates, all used names hast to be there:
For internal access:
yourinternalserver.int_domain.tld
yourinternalserver (if you want OWA to call it this way...
autodiscover.int_domain.tld (if you use autodiscover internally)

For external access:
yourexternalserver.ext_domain.tld
autodiscover.ext_domain.tld (if you use autodiscover externally)

The external certificate names has to be implemented, where the external client accesses you network. I.e. if TMG is used, these names has to be in the certificate, which is connected with the web listener for OWA on TMG.

Other firewalls depend on the configuration.
If they just route through, they have to be added on the exchange certificate.
If the firewall uses a listener port (NAT), you have to add a certificate with these names there (usual case).

If you don't use external access, leave all the external names and settings out.
0
 

Author Comment

by:Gazza007
ID: 38436193
Thanks Bembi and JJ
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

User Beware!  This is a rather permanent solution to removing your email from an exchange server.  The only way to truly go back is to have your exchange administrator restore your mailbox from backups.  This is usually the option of last resort.  A…
Deploying a Microsoft Access application in a Citrix environment is not difficult but takes a few steps. However, Citrix system people are often of little help, as they typically know next to nothing about Access. The script provided here will take …
The viewer will learn how to use a discrete random variable to simulate the return on an investment over a period of years, create a Monte Carlo simulation using the discrete random variable, and create a graph to represent the possible returns over…
The viewer will learn how to create two correlated normally distributed random variables in Excel, use a normal distribution to simulate the return on different levels of investment in each of the two funds over a period of ten years, and, create a …

581 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question