• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1983
  • Last Modified:

TSGateway service missing on SBS2011

Just took over looking after an SBS2011 server, and have found the "tsgateway" ("Remote Desktop Gateway" service is missing (the BPA told me it wasn't started, in fact it's not there at all).

As you might expect, users can't connect to PCs using Remote Web Access as a result.

I know that it's a special case with SBS2011 in that the tsgateway service is installed but it looks like it isn't - so I don't want to try to add it as a role/feature as I think this may break it.

What's the best way to reinstall the service?

Thanks in advance.
0
David Haycox
Asked:
David Haycox
  • 2
  • 2
1 Solution
 
DrDave242Commented:
0
 
David HaycoxAuthor Commented:
That looks like the right thing!  Just tried it and it doesn't work though... the log file reads:

<?xml version="1.0"?>
<TaskStatusResults xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <TaskStatus Time="2012-09-13T19:30:02.9665852+01:00" Success="false" Continue="true" Expose="false" Reboot="false" RebootNow="false" Completed="true" Message="Remote Desktop Gateway did not install" TaskListId="ConfigureRDPTaskList" Warning="false" HelpTopicId="html\814a60b1-2711-4dfa-a58f-81fd968fd6f6.htm" StatusId="9cf1ec4f-f16f-4237-9d57-3f5533af9405" UserStatus="Active">
    <Task Id="ConfigureTSGCertificateTask" Type="Microsoft.WindowsServerSolutions.IWorker.Tasks.ConfigureTSGCertificateTask" Assembly="IWorkerConfig.dll" AlwaysReboots="false" />
  </TaskStatus>
  <TaskStatus Time="2012-09-13T19:30:03.9530452+01:00" Success="false" Continue="true" Expose="false" Reboot="false" RebootNow="false" Completed="true" Message="Remote Desktop Gateway did not install" TaskListId="ConfigureRDPTaskList" Warning="false" HelpTopicId="html\814a60b1-2711-4dfa-a58f-81fd968fd6f6.htm" StatusId="8818e193-5a96-484a-bce0-1768e9aea238" UserStatus="Active">
    <Task Id="ConfigureTSProxyTask" Type="Microsoft.WindowsServerSolutions.IWorker.Tasks.ConfigureTSProxyTask" Assembly="IWorkerConfig.dll" AlwaysReboots="false" />
  </TaskStatus>
</TaskStatusResults>

Perhaps there's some other problem as well; any ideas?  Thanks.
0
 
David HaycoxAuthor Commented:
Sorted it.  The Network Policy Server service was also missing (although it was listed in role services), so after a reboot the solution given above would have worked, but for the missing dependency.  I removed and re-installed Network Policy Server, then rebooted again.

This got the services all running, which just left me to configure the RAP and CAP policies, which I did by enabling the Remote Desktop Gateway Manager with this:

dism /online /Enable-Feature:Gateway-UI

Then comparing policies (or lack of them) to a known good SBS2011.
0
 
DrDave242Commented:
Good deal!  Glad you got it working.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now