Exchange 2010 Died!

This is a new server that was working fine.  

Just tried to log into OWA and test some public folder replication (that was working) but noticed that there was a problem.  Logging onto the exchange console i get attached.

Ideas?
exchange.bmp
LVL 1
CHI-LTDAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LeeDerbyshireCommented:
I would check that the WWW publishing service is still running on the server.
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Firstly, Check if IIS and WWW service is running
Secondly, was any changes done to the server with SP ?

- Rancy
CHI-LTDAuthor Commented:
It does look related to IIS, after i have been configure FTP.....
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

CHI-LTDAuthor Commented:
WWW and IIS are running.

So, i have installed the FTP role and added an FTP site configured permissions for it.  This appears to have screwed it.  
The default Web Site bindings are less then that of my DR server.
Sushil SonawaneCommented:
checke the iis and www services running or not.

If it's running state then run the command iisreset then check.

If still issue not resovled then please refer below link to troubleshoot.

(http://social.technet.microsoft.com/Forums/en-IN/exchange2010/thread/b84af26d-932d-4862-8e46-622d3167dfd7)

(http://blogs.technet.com/b/exchange/archive/2010/02/04/3409289.aspx)
CHI-LTDAuthor Commented:
and i get (when browsing OWA site):
exchange2.jpg
joyofsharingCommented:
Dear CHI-LTD

Hope this helps you.

Exchange 2010 Management Console Initialization Failed


joyofsharing
LeeDerbyshireCommented:
The error screen shot you posted is just saying that the server will not provide a detailed error description to remote clients (i.e. clients other than browsers running on the server itself).  Try accessing OWA from the server's own browser, and see if you get a better error message.
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
Can you browse OWA inside IIS if not maybe as i said you might need to recreate Virtual Directories :(

- Rancy
CHI-LTDAuthor Commented:
Attached shows the localhost accessing OWA.
CHI-LTDAuthor Commented:
Ah, i also have changed the clock time by 2minutes earlier...
LeeDerbyshireCommented:
Sorry, can't see any attachment.
CHI-LTDAuthor Commented:
exchange2.jpeg
CHI-LTDAuthor Commented:
Can someone confirm to me their Site Bindings?

My live site has 5.  My DR site has 8
CHI-LTDAuthor Commented:
The clocks are all the same...
LeeDerbyshireCommented:
Sorry, still can't see the attachment.  I can see where you tried to put it (because the name is there), but I think something went wrong.

My default web site has 8 bindings.  Probably the same as your DR site (I'm not sure what DR means, though).
CHI-LTDAuthor Commented:
Disater Recovery.  Right i'm going to manually add the one missing...
CHI-LTDAuthor Commented:
But it wont let me add anything other than Http or https.  Whereas my other server does.  

Anyone know where these settings are stored so i can restore from my working box or the option to allow me to enter in these missing settings>?
Simon Butler (Sembee)ConsultantCommented:
If you have screwed up IIS, I would reinstall it and the CAS role.
http://support.microsoft.com/kb/320202

Follow the instructions for Exchange 2007.

FTP on an Exchange server? Not required and should be kept away from a domain machine.

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LeeDerbyshireCommented:
You only see http and https in the dropdown list when you add the bindings?  I've no ideas where that list comes from.  But I'd have thought that the existing http and https bindings were sufficient.

Any chance of that attachment yet?  Or copy/paste the text?

Or, you might try the reinstall as suggested by Sembee the second.
CHI-LTDAuthor Commented:
Sure.  The others are missing.
Attached.
exchange2.jpg
LeeDerbyshireCommented:
Can you find the web.config file mentioned in the error page, and make the suggested change.  Then we can see the full 'uncensored' error message.
CHI-LTDAuthor Commented:
Maybe.  Im going to attempt a restore of the default app pool config file from yesterday and see what happens (the exchange box hasnt any live mailboxes or routing mail as yet so its worrth it i think!
CHI-LTDAuthor Commented:
Didnt work.  I'll try your idea.
CHI-LTDAuthor Commented:
ok im getting an event log showing:


Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 13/09/2012 18:02:57
Event time (UTC): 13/09/2012 17:02:57
Event ID: c6d38c29b8fd4f648470b878625dc0d4
Event sequence: 1
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/1/ROOT/PowerShell-1-129920293762814760
    Trust level:  
    Application Virtual Path: /PowerShell
    Application Path: C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell\
    Machine name: CHI-EXCH
 
Process information:
    Process ID: 7644
    Process name: w3wp.exe
    Account name: NT AUTHORITY\SYSTEM
 
Exception information:
    Exception type: HttpException
    Exception message: The current identity (domain\xerox) does not have write access to 'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files'.
 
Request information:
    Request URL: http://exch.domain.local/PowerShell?PSVersion=2.0 
    Request path: /PowerShell
    User host address: fe80::50f4:3898:7fd4:a8bf
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: domain\xerox
 
Thread information:
    Thread ID: 1
    Thread account name: domain\xerox
    Is impersonating: False
    Stack trace:    at System.Web.HttpRuntime.SetUpCodegenDirectory(CompilationSection compilationSection)
   at System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags)
 
 
Custom event details:


This was caused by me adding the ftp site to IIS for sure as its using our xerox account somewhere.

Question is, where?
LeeDerbyshireCommented:
Probably the application pool identities have been changed.  For .net v2, I think it should be ASPNET.  But 'Network Service' is usually good.
Exchange_GeekCommented:
You can get IIS working quicker than trying to fix it. Re-install IIS and CAS and that should help you.

You're lucky there are no live mailboxes on this box.

Here is the link I'd work with
http://technet.microsoft.com/en-us/library/ff629372.aspx

Regards,
Exchange_Geek
CHI-LTDAuthor Commented:
Yes i know, very.  I might even restore from backup as its a VM...
CHI-LTDAuthor Commented:
Ok, i have tried restoring VM backups to a test VM network with no ESXI host hics, (so the restored VM isnt on the live network).
The restored VM has retained its IP address but the restores (tried 3 going back a week) are still coming up with the same errors.

So, is this because the restored VM isnt on the live network and cannot see DC's / AD etc.  
or
Is it because the VM was screwed some time ago (which i find it hard to believe as i sent myself emails and received emails to a mailbox on this server on the 10th Sept...)?

I really dont want to have to start uninstalling / reinstalling new services/roles...
CHI-LTDAuthor Commented:
Update, restored the VM onto the live network and ll looks good!!!!   So far...
CHI-LTDAuthor Commented:
restored the VM from backup...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.