How to set up local web server for Rad-7 testing

Posted on 2012-09-13
Last Modified: 2013-04-25
I have a java / jsp web application that I maintain, but infrequently. I just tried to make a small change but can't get the local server started, it's been a while but everything worked fine in the last round of changes.

PC has since been upgraded to Windows-7 which caused a fair amount of issues, which I've been able to correct one by one. For example, Rad-7 had to be re-installed and that seems ok - I can open the application from my workspace, and that seems ok. Then I got source code control connected to Dimensions, etc. But now trying to start the server and it's not opening, see log file.
- The log file says "Server server1 open for e-business", but later says "Conflict detected on port 8881.  Likely causes: a) An instance of the server server1 is already running  b) some other process is using port 8881" (unlikely that another server is running)

The help says to open the Administrative Console, but I'm not sure how to do that.
Question by:Alaska Cowboy
    LVL 26

    Accepted Solution

    The short answer is that the error message is telling you all you need to know -- something is already listening on port 8881 .  Get a cmd window and type
    netstat -a
    and look for 8881 .  That will tell you what to kill or not to run your app.  It sounds as if RAD7 was already started when you tried to start it again.

    Are you asking how to get to the RAD7 Administrative Console?  Check the basic, doc, or search ee:
    The url is http://localhost:9060/ibm/console/ .

    The long answer is that it sounds as if you are porting a webapp within RAD7 to Windows 7.  It's a lot of work, and you'd be much better off if you could have the developers of the webapp do the port, or have them answer your questions as to why it's having conflicts.

    However, if you want to port it yourself, then you need to post a lot more information and source code about the problem.
    LVL 1

    Author Comment

    by:Alaska Cowboy
    Ok, I will check on this Monday, thank you.
    LVL 1

    Author Comment

    by:Alaska Cowboy

    sorry for the delay.

    >>Get a cmd window and type netstat -a, and look for 8881
    - did that, don't see 8881, see attached.

    >>It sounds as if RAD7 was already started when you tried to start it again.
    - I don't think so, after upgrading to W-7, then I had Rad-7 installed, so I doubt anything was running.

    >>Are you asking how to get to the RAD7 Administrative Console?
    - yes, but I thought that was done within RAD-7 itself . . . I don't understand how a URL has the Admin console. I tried the link above and those in the EE post you referenced, none of them work.

    >>it sounds as if you are porting a webapp within RAD7 to Windows 7.
    - not exactly sure what you are asking about porting the app . . . I have a web application, then upgraded to W-7 and re-installed Rad-7, shouldn't it work if Rad-7 is properly installed ?

    The issue is my webserver won't load, so my take is the Rad-7 installation isn't in order, wouldn't this be a separate issue from porting the app ?

    Thank you.
    LVL 26

    Assisted Solution

    You said in your original post that you had RAD7 running and that you could access it.  Now it sounds as if that's not so.

    The port conflict message seems to be common -- I googled for it, and you should try that as well.  You might recognize some of the responses as matching your environment.  This site has some suggestions re: tracking down the 8881 conflict:
    You're right, I don't see 8881 in the netstat you posted.

    Many products use urls for their admin consoles, hence the localhost:9060 url.

    We don't have a ton of RAD7 experts here, but there might be some.  Ask a different question on EE -- put Websphere, RAD7 and the port console conflict in your question -- that might help.  It sounds as if there's a problem with your RAD7 configuration, you're not yet at a problem with your Java code.
    LVL 1

    Author Comment

    by:Alaska Cowboy
    sorry for the delay. I will google the port conflict messages as you suggest. This is low-priority for me, but I still need to resolve it.
    LVL 1

    Author Closing Comment

    by:Alaska Cowboy
    this project is on hold for me, so I won't be able to pursue for a while. I apologize for letting this hang so long.

    Featured Post

    6 Surprising Benefits of Threat Intelligence

    All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

    Join & Write a Comment

    Suggested Solutions

    Title # Comments Views Activity
    hash value 2 29
    wordsCount challenge 10 49
    parentbit challenge 3 38
    @SBGen Method 3 18
    Introduction As you’re probably aware the HTTP protocol offers basic / weak authentication, which in combination with the relevant configuration on your web server, provides the ability to password protect all or part of your host.  If you were not…
    In this post we will learn how to connect and configure Android Device (Smartphone etc.) with Android Studio. After that we will run a simple Hello World Program.
    Viewers will learn about basic arrays, how to declare them, and how to use them. Introduction and definition: Declare an array and cover the syntax of declaring them: Initialize every index in the created array: Example/Features of a basic arr…
    Viewers will learn about the regular for loop in Java and how to use it. Definition: Break the for loop down into 3 parts: Syntax when using for loops: Example using a for loop:

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now