[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 262
  • Last Modified:

Trackpad firmware doesn't update and now stopped working (Lion & MacBook 13" Unibody)

I bought an oldish MacBook 13" Unibody (late 2008) and when I got it one of the first things I did was to install Mac OS X Lion.

Everything was working fine, until I applied an update that made the trackpad stop working (it only accepts clicks, no touch is recognized).

This is the "Trackpad Firmware Update" from the automatic updates (link below).

When starting this firmware update a window appears with a status message, Cancel and Update buttons. After clicking the Update button, it starts installing, appears to complete, status changes to Finishing..., and Update button comes back active at some point.

After that I have tried (unsuccessfully):

downloading and installing the update directly from Apple Support - http://support.apple.com/kb/HT3288
same thing, but using the 'root' account
leaving the computer on overnight to see if actually "finished" the process
Hand palm pressing over 30 seconds on the trackpad (read this on another thread...?)
Reinstalling Mac OS X Lion using a DVD
Indifferent to USB devices being connected or not


I've also tried most (or all) of this after reverting to Snow Leopard.


I'd be thankful for any ideas to try out.
0
acseven
Asked:
acseven
  • 3
1 Solution
 
Davis McCarnOwnerCommented:
0
 
acsevenAuthor Commented:
As stated, it's a MacBook Unibody 13 inch, late 2008 version.
http://support.apple.com/kb/sp500
coincides with that link
0
 
acsevenAuthor Commented:
Hi,
This issue was solved by an Apple technician.
0
 
acsevenAuthor Commented:
No solution was suggested.
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now