Exchange Server 2010 Setup for a Lab. Godaddy Domain Registered.

Hi

I have two VMs running on VMWare Fusion. One is a DC running Windows Server 2008 R2 Enterprise Edition.
Another is an Exchange Server 2010, with a typical installation. (CA, MB & HT Roles)

Basically my goal is, i want my Exchange Setup to be publicly available with the least amount of expenses.

I have a domain - mydomain.com which is registered with GoDaddy.com
Now in their DNS Manager, i can see that there are 2 MX Records that are being created by default. And there are lots of CNAMEs also

there is a CNAME
1. mailstore1.secureserver.net
2. smtp.securesesrver.net

Under MX Records the first and second one is specified with priority 10 and 0.

Now, do i have to change these to mail.mydomain.com in the CNAME and the MX Record Section.

moreover, in the Exchange HUB TRANSPORT role, i specified mailstore1.secureserver.net first and tried. Then i tried smtp.secureserver.net. But it says it doesnt accept.
I tried to telnet to mailstore1.secureserver.net and the same thing

Please help me achieve my objective.

Thanks
Syed Mohammed Sirajuddin
LVL 1
brandscoAsked:
Who is Participating?
 
Nagendra Pratap SinghConnect With a Mentor Desktop Applications SpecialistCommented:
You are pretty much on your own now.
0
 
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
The registrar for this is WILD WEST DOMAINS, LLC. (secureserver.net)


Anyway, do you have a fixed IP address from the ISP? Does your router forward port 25 to your Exchange server?

What is your router model?
0
 
brandscoAuthor Commented:
I have a normal ADSL router which provides a typical home internet.
the domain my domain.com has a Public IP i mean my domain.com always resolves to an IP.

I am not using cisco or any other enterprise level routers. but in this router/modem the port 25 should be open, because when i telnet to mailstore1.secureserver.net i get the below..

MacBookPro:~ syed$ telnet smtp.secureserver.net 25
Trying 216.69.186.201...
Connected to smtp.secureserver.net.
Escape character is '^]'.
554-m1pismtp01-035.prod.mesa1.secureserver.net
554 Your access to this mail system has been rejected due to the sending MTA's poor reputation. If you believe that this failure is in error, please contact the intended recipient via alternate means.
Connection closed by foreign host.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
I get this

mx:secureserver.net      smtp.secureserver.net      72.167.238.201
0
 
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
Using tools-on.net, I get this. I got the same use MXTOOLBOX
===========================================


General Information
Hostname
smtp.secureserver.net
IP
72.167.238.201
Reverse name
p3pismtp01-v01.prod.phx3.secureserver.net
Preferable MX
smtp.secureserver.net
Network Information
Owner
#
Location
# Query terms are ambiguous. The query is assumed to be:# "n 72.167.238.201"## Use "?" to get help.#
Contact Information
72.167.0.0 - 72.167.255.255, CIDR: 72.167.0.0/16, OriginAS: AS26496, NetName: GO-DADDY-COM-LLC, NetHandle: NET-72-167-0-0-1, Parent: NET-72-0-0-0-0, NetType: Direct Allocation, RegDate: 2007-07-05, Updated: 2012-02-24, Ref: http://whois.arin.net/rest/net/NET-72-167-0-0-1
0
 
Simon Butler (Sembee)ConsultantCommented:
The two hosts that you have listed for MX records are GoDaddy's default SMTP servers.
You first need to create a new host name to point to your Exchange server.
If you are on a home connection and haven't chosen to have a static IP address you will be on a dynamic address - therefore you are going to need a dynamic DNS service.

http://exchange.sembee.info/network/dynamicip.asp

Map your preferred name to the dynamic DNS host name as a CNAME.

Forget about the secureserver.net addresses, where you have put them in Exchange remove them.

Simon.
0
 
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
Frankly I don't understand why do you want to run a commercial site with such a hobby type infrastructure?

You can ask your ISP for a fixed IP address. This will cost like 20 % extra . Then update the MX record to this fixed IP address.
0
 
brandscoAuthor Commented:
this is for my lab setup. thats the reason..
0
 
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
Sorry! Missed that in the title.
0
 
brandscoAuthor Commented:
Its Ok npsingh123.. Experts, any other suggestions or references please ???
0
 
Simon Butler (Sembee)ConsultantCommented:
You have been provided with a lot of information already, but haven't really provided much feedback, therefore anything further is impossible to say.

Simon.
0
 
brandscoAuthor Commented:
hi. i went ahead and purchased the dynamic DNS service and created an alias name such as

mail.mydomain.com points to hostname.dyndns.org

Now when i ping mail.mydomain.com i get the reply from the dynamic public IP address currently assigned on my modem by the ISP.

Now i am stuck in accessing this owa and other things from the internet.

I have configured the Client Access Server and checked the DNS Server Settings on my domain controller also, and seems its ok.

please help
0
 
Simon Butler (Sembee)ConsultantCommented:
What do you mean by "stuck"? You haven't really said what you have done other than create the host.

Have you checked the ports are open on the firewall?
Can you browse to OWA?

You need to provide more information.

Simon.
0
 
brandscoAuthor Commented:
Hi Sembee2.. Please dont think that everyone will be as experienced as you are and you are sounding so rude..

Ok. i have checked that the ports 25 on the modem/router is open
i can browse to OWA internally via https://mail.mydomain.com/owa

What more information can i give. Please understand that i am starting to learn.
0
 
brandscoAuthor Commented:
i have tried opening ports 80, 443 also.. but no response..
0
 
Simon Butler (Sembee)ConsultantCommented:
I don't think I am being rude. I am not in front of your server, I can only go by what you have written. That means you have to say everything that you have or have not done, you cannot presume that something that is obvious to you is obvious to posters on a forum because it is not. We cannot presume anything. If you still think I am being rude then I will just drop off the question, because I am not wasting any more of my time.

You only need to open two ports - 443 and 25, no other ports need to be open. They need to map to the internal IP address of the server within the router. OWA working correctly internally is fine, that means you don't have a problem with the application, the issue is with the networking and router configuration. Ensure the server can access the internet correctly, and use one of the external IP address viewing sites to ensure that the address they see is what you are expecting.

Simon.
0
 
brandscoAuthor Commented:
Hey.. Do you think you want me to tell you everything i did?? I can post only for which i have problems with..

All these years using EE, i have seen only one person like you.. Amazing..

Please dont waste your time and show your talents on any other question or posts, where you see posts which are in detail like a novel..

I have done that too before posting it so this suggestion is also not helping me.. I dont want replies from Simon.. Further posts please avoid.


Thanks
0
 
brandscoAuthor Commented:
Other Experts.. please assist me if you can.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.