Win Server 2k8 R2 / Oracle Client 10g / ODAC

Posted on 2012-09-14
Last Modified: 2012-09-14
Hi Guys,

I have a Windows Server 2008 R2 and an ASP.NET application that needs to connect to an Oracle 10g 64-bit Database (hosted on another server) using an ODBC connection.

I have installed Oracle 10g Client (10.1) and have successfully connected to the database using SQL Plus.

I have tried to install the driver for the data source (ODAC 10.1), but I am getting "Abnormal program terminiation...unknown. unknown. unknown....

I decided to give 11g R2 a try. I was able to install both the client (11.2) and ODAC (11.2), but I don't see the ODBC driver listed when I attempt to create a data source.

Any suggestions?
Question by:rmartes
    LVL 76

    Accepted Solution

    >>I was able to install both the client (11.2) and ODAC (11.2),

    No need to install both.  One or the other would work.  Also for ODBC you can use the Instant Client.

    Did you install the ODBC drivers?  I don't think the regular client installs them by default and I think ODBC is an option on the ODAC install as well.

    You also need the same Bit version the .Net app is compiled for.  I would suggest you not compile it for AnyCPU.  This has caused some problems when looking for Oracle drivers.

    I doubt you can change it now but I would strongly suggest you use ODP.Net to connect a .Net app to Oracle not ODBC.

    Author Comment

    Thank you so much for the help slightwv. I decided to give ODP.NET a try. I placed Oracle.DataAccess.dll into my app's bin folder and slightly modified the connection string. However I get the following error when executing OracleDataReader = dbCommand.ExecuteReader():

    Oracle.DataAccess.Client.OracleException: ORA-24333: zero iteration count

    Author Closing Comment

    Nevermind, I got it working. I had an error in my sql. Thanks.
    LVL 76

    Expert Comment

    by:slightwv (䄆 Netminder)
    Glad to help.

    One final thing as you move forward:  When you go to deploy the app you must have the exact same ODP.Net version on the host machine that was used to compile the app.

    There is a work-around where you can force versions using the app.config in this question:

    There is also a work-around where you can copy 5 Oracle DLLs and not worry about an install at all:

    Featured Post

    PRTG Network Monitor: Intuitive Network Monitoring

    Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

    Join & Write a Comment

    Note: this article covers simple compression. Oracle introduced in version 11g release 2 a new feature called Advanced Compression which is not covered here. General principle of Oracle compression Oracle compression is a way of reducing the d…
    Background In several of the companies I have worked for, I noticed that corporate reporting is off loaded from the production database and done mainly on a clone database which needs to be kept up to date daily by various means, be it a logical…
    This video shows syntax for various backup options while discussing how the different basic backup types work.  It explains how to take full backups, incremental level 0 backups, incremental level 1 backups in both differential and cumulative mode a…
    This video shows how to recover a database from a user managed backup

    755 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now