Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 715
  • Last Modified:

Autodiscovery Exchange 2010 Domain mismatch

Hello!

I'm having this issue with Autodiscover in Outlook 2011.  I'm migrating our server from Exchange 2003 to Exchange 2010 and ideally I would like to have everything working.  

Here's the setup:
Internal users are user@localdomain.com
Email addresses are user@website.com
Old: Exchange 2003 on Windows 2003
New: Exchange 2010 SP1 Version 14.02.0318.001 on Windows 2008 R2

I know the standard procedure is normally website.local but this is how it was setup when I got here.

When my Outlook clients are configured using autodiscover, they are discovered with the wrong e-mail address. They are discovered with their local domain account (ex: user@localdomain.com) instead of their actual e-mail address (ex: user@website.com). Both of these addresses are set as SMTP addresses on the accounts, but the external user@website.com SMTP is always set as the primary. Why is autodiscover grabbing the local domain SMTP?  It seems to work OK on the Windows machines running Outlook 2007+, but for some reason, the autodiscover doesn't work properly in Outlook 2011 on the Mac's.

In Outlook 2011 (Mac), if I put the user@website.com and password, it fails.  The moment I type in user@localdomain.com and the same password, it autodiscovers everything and works.

Thoughts?

Jon
0
JMF85
Asked:
JMF85
1 Solution
 
David Johnson, CD, MVPOwnerCommented:
check your dns autodiscover settings .. how are they  users using exchange? pop/imap/exchange ?
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
What is the Autodiscover DNS entry pointing to and what information is in the certs ?

- Rancy
0
 
johan_vCommented:
Hi,

Which autodiscover records dns records did you create? Windows machines will use the SCP to search for the autodiscover but I have seen strange issue with Outlook 2011.

In most cases you can solve this issue by creating a pin point dns record. This is a record which contains only the autodiscover.website.com address so is not a complete split dns which is not always possible.

To add the pinpoint dns run the following cmdlet from a dos prompt:

dnscmd . /zoneadd autodiscover.website.com. /dsprimary
dnscmd . /recordadd autodiscover.websitecom. @ A 192.168.1.25

Once thing that is really important is that the autodiscover.website.com is included on the certificate which is installed on your Exchange server.

Regards,

Johan
0
 
JMF85Author Commented:
Certificate (Purchased a 10 domain UCC):
mail.localdomain.com
anywhere.localdomain.com
autodiscover.localdomain.com
servername.localdomain.com
autodiscover.website.com
owa.localdomain.com

Users are connecting to Exchange directly via client (and Activesync).  Autodiscover.localdomain.com is an A record that points to the internal IP address of the new mail server.  I have also created an A record for autodiscover.localdomain.com and autodiscover.website.com at our registrar that points directly to the external facing IP of the exchange server.

@johan_v What does the above commands do exactly and are their any ramifications of doing this? Also, if something messes up, how do I back it out.  Thanks :).

Thanks,

Jon
0
 
johan_vCommented:
Jon,

Well with creating the pint point dns in your internal dns you can point it directly to your cas servers internal ip and not it's external ip. This will prevent any firewall or something from blocking something.

To investigate the issue you can enable Outlook logging to see what the problem is exactly.

Regards,
Johan
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now