404 returning when trying to access a controller action

Posted on 2012-09-14
Last Modified: 2012-09-18
I have a action in my account controller called register().. It always returns a 404 when trying to go to it..please help!!
Question by:cbrune
    1 Comment
    LVL 21

    Accepted Solution

    What have you tried so far to solve the problem?

    Have you used Fiddler to watch the traffic and ensure the correct request is being sent to the web server?

    Do your other actions on that controller work correctly?

    Do actions on other controllers work correctly?

    Does the action have any attributes on it? Specifically, does it have an [HttpPost] attribute?

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    Join & Write a Comment

    Today is the age of broadband.  More and more people are going this route determined to experience the web and it’s multitude of services as quickly and painlessly as possible. Coupled with the move to broadband, people are experiencing the web via …
    This article is for Object-Oriented Programming (OOP) beginners. An Interface contains declarations of events, indexers, methods and/or properties. Any class which implements the Interface should provide the concrete implementation for each Inter…
    This video discusses moving either the default database or any database to a new volume.
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    731 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now