• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 762
  • Last Modified:

ESXi 5.0 NFS Problem

Hi, I have a ESXi box that has an Windows Server 2008R2 VM which has some NFS shares.  These shares were mounted as storage in ESXi.  Unfortunately, I made the mistake of changing the IP address of the Windows VM and now, not only have I lost access to those NFS shares, I also cannot mount or unmount the old shares.  Unfortunately, I don't know the old IP addess (I switch from DHCP to static IP).  I tried to list the shares in ESXi using the command esxcfg-nas -l, so I can manually unmount them, but I get an error which says it cannot resolve the hostname.  And anything I try to do to add a new NFS share gives me that same message - even if I try to add a share on another server with a different hostname.

Any help would be appreciated.
0
Hammer8
Asked:
Hammer8
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
just create a hosts file on the ESXi server or DNS entry for the hostname of the new IP Address of the NFS server.
0
 
Paul SolovyovskyCommented:
On the ESXi host go to configuration/storage.  If you still have the links to the datastores there they should have an IP address that it was pointing to.  Better use IP versus hostaname I find as I've seeen strange resolution issues
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now