Can't access /owa and /remote on SBS 2011 externaly

Posted on 2012-09-15
Last Modified: 2012-10-17

Here is my problem.  I can't access my /owa or /remote externaly on sbs 2011. It worked before and I don't know the reason why it stopped working. I can access the site with my internal ip/owa and /remote but externaly I can't. I've tried to open all the ports linked to sbs 2011 (25, 80, 443, 987, 3389) but that doesn't work. After that, I even put the sbs server in the dmz to be sure that something else wasn't blocking this but it still didn't work.

In IE I get a 404 error and in chrome I get this error : getfile: Cannot open URL(/etc_ro/web/owa,No such file or directory)

To test, I tried to access remote desktop with the mstsc command and the external ip adress and it worked.

Please help,
Question by:remimcgraw
    LVL 56

    Expert Comment

    by:Cliff Galiher
    Looks like you are hitting a different server with its own root directory set up. This would imply a problem with your external DNS setup.

    Author Comment

    There is only one server in this network. Also when I connect via mstsc I get the right machine.
    LVL 56

    Accepted Solution

    You said you connected by IP address though. And I'm not saying you are connecting to another machine on your network. That would imply a firewall/port forwarding rule.

    I said it looks like an external DNS issue. So even if your firewall is right, if you are connecting to another server on the internet (may not even be your server) all the port forwarding in the world won't matter.

    The /etc_ro/web directory is a fairly common Linux web host directory. So based on the error you provided, I suspect tour external DNS record now points to a web server. Maybe your company's hosted website. Or maybe someone else's server. I can't say for sure.

    Author Comment

    Thanks for the clarification, I will take a look at this and get back to you. Thanks

    Author Closing Comment

    I forgot to close this before but it was a camera system that an employee just installed that had a linux webserver built in that was causing the troubles.  You were right about connecting to the wrong server, thanks a lot!

    Featured Post

    What Security Threats Are You Missing?

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    Join & Write a Comment

    Back in July, I blogged about how Microsoft's new server pricing model, combined with the end of the Small Business Server package, would result in significant cost increases for many small businesses (see SBS End of Life: Microsoft Punishes Small B…
    A quick step-by-step overview of installing and configuring Carbonite Server Backup.
    In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
    This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

    746 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now