Finding drivers for RealTek

Hello,

I've just upgraded my OS from Win Vista to Win7, using a clean install.
I've found all of my drivers so far, with the exception of my network adapter - Realtek PCIe FE Family Controller.

I'm using a Toshiba Satillite A305-S6872 and the drivers on the Toshiba site haven't worked.  

How can I get some trustworthy drivers for this device?
Thanks
--TripWire--Asked:
Who is Participating?
 
Scott ThompsonComputer Technician / OwnerCommented:
This is a longshot, but have you tried updating the BIOS?
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=DL&os=&category=&moid=2140534&rpn=PSAG8U&modelFilter=A305-S6872&selCategory=2756709&selFamily=1073768663

I'm not sure why you had display issues after installing the drivers from the Realtek website, but it might be that the system cannot use 'generic' drivers and it has to be the drivers from the Toshiba website.

You say that the network port is NOT lighting up when you plug in a cable.  Are you able to test the connection on a different computer, to make sure that the network cable is working fine?

Also check inside the port to make sure that there are no bent pins.  If even one of the eight pins are bent, it can cause the system to not recognize a plugged in cable.

Last question, are you able to hook up wirelessly just fine?

EDIT: Okay, next last question :)  Did the network port work fine BEFORE you upgraded to Windows 7?
0
 
djsharmaTechnical ConsultantCommented:
You can download driver and install from http://download.cnet.com/windows/
0
 
nobusCommented:
if you have known, or unknown devices in device manager, you can use this procedure to identify them :

Start>Programs>Accessories>System Tools>System Information.
Now select  "Components" and highlight "Problem Devices".
All hardware devices with a driver problem will be listed here.
Make a note of the first line of the PNP Device ID line of the entry. It will show a Vendor number and a Device number (VENxxxxDEVxxxx) both four digits long.
post them here - or google them
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
Scott ThompsonComputer Technician / OwnerCommented:
You can usually go to www.realtek.com.tw to download the latest drivers for your NIC. It will probably be these drivers.
 http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=7&Level=5&Conn=4&DownTypeID=3&GetDown=false
0
 
SandeepSr System AdministratorCommented:
Have you tried downloading these set of drivers?

http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=DL&os=&category=&moid=2140534&rpn=PSAG8U&modelFilter=A305-S6872&selCategory=2756709&selFamily=1073768663

These are specifically for Windows 7 (32bit), Windows 7 (64bit) and provided by Toshiba itself so I believe it should work out. Could you please try these and update us?
0
 
nobusCommented:
>>  the drivers on the Toshiba site haven't worked  <<  what happened?  post erros, or messages
0
 
--TripWire--Author Commented:
nobus - There were no errors, the network card just isn't responding or lighting up when I plug my ethernet cable in.
The Device Manager says that I have the driver for Realtek 7.46.610.2011

pc_solutions - when I setup those drivers, the network card doesn't respond, and now I'm having some display issues, so I will have to roll back.  I don't see an uninstall option.

djsharma - that site doesn't have what I'm looking for.  Those are only audio drivers.


Any other solutions?
0
 
nobusCommented:
did the lan card work under Vista? if not, it ccan simply be  a bad lan card
also -post VEN and DEV values, as asked

if you suspect a bad lan card, you can test if it works by booting from a live Knoppix cd - you should be able to access internet :  ftp://ftp.gwdg.de/pub/linux/knoppix/KNOPPIX_V6.7.0CD-2011-08-01-EN.iso
0
 
--TripWire--Author Commented:
nobus and pc_soloutions...
I can rule out any hardware issues with the port because it was working perfectly before I installed the OS, and it only took about 1 1/2 hrs, so it's safe to assume that nothing happened to the port/cable in that time.

I am able to use the wireless just fine, that's how I'm able to post using the same laptop.

I will try running the BIOS update now.  Hopefully it's low-risk.
0
 
--TripWire--Author Commented:
Good call on suggesting the BIOS.  It seems to have worked now.  Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.