• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 597
  • Last Modified:

Forwarding of mail to external address does not work

Im administrating an old SBS2003. Some of the users wants their corporate email to get forwarded to an external email address.
To accomplish this i set up a contact and mail enable this with the external mail address as primary address.
Then i use delivery option under the user to forward the corporate mail.
I have done this several times in the past but for some reason this is not working with this server.
Any suggestions?
0
Ohmit
Asked:
Ohmit
  • 3
  • 3
  • 2
  • +2
6 Solutions
 
davorinCommented:
Do you see and trace of that forwarded mail in queue or in SMTP logs?
Try to manually send email to that contact.
0
 
OhmitAuthor Commented:
Thank you for your input.
Trace it??
I can verify that the external address is working perfectly by itself
0
 
davorinCommented:
sorry, typo - Meant "Do you see any trace"
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
davorinCommented:
If there is no sign of that message try to check event log.
If even there is no info, try to use message tracking center.

Some links:
http://www.msexchange.org/tutorials/Exchange-2003-Message-Tracking-Logging.html
http://support.microsoft.com/kb/821910
0
 
footechCommented:
Do you have the option set to allow automatic forwarding in ESM under Global Settings > Internet Message Formats (select Default > Properties)?
Does auto-forwarding work to an internal recipient?
0
 
WORKS2011Austin Tech CompanyCommented:
When you created the contact did you choose "Custom Address" or "SMTP Address", should be SMTP address.

For troubleshooting purposes delete the contact and recreate to eliminate it as a possibility and / or create a new contact to gmail for example to make sure creating a contact and forwarding works at all.

Let us know.
0
 
Simon Butler (Sembee)ConsultantCommented:
You do NOT have to enable the automatic forwarding option in ESM to use a contact to forward email to an external account. Therefore if you have enabled that option, disable it.

Message Tracking is the key tool here, as that will tell you whether the forward has been successful or not.

However, the forwarding method that Exchange uses, will not be 100% successful, and it depends on the configuration of two elements that you cannot control - the sender domain and the recipient domain (where you are forwarding email to). The forwarding method Exchange uses leaves all of the header information in place. What that means is that if either domain is using methods to detect spoofing, then the email will be blocked. The Recipient site would have to white list your Exchange server from any of those tests to ensure that it works correctly, if the emails are being forwarded to a public service (Hotmail, AOL, ISP mailbox) then that is going to be impossible and therefore the use of forwarding should be discouraged.

Simon.
0
 
footechCommented:
@ Sembee2 - "You do NOT have to enable the automatic forwarding option in ESM to use a contact to forward email to an external account. Therefore if you have enabled that option, disable it."  Thanks for correcting me.  I was thinking about forwarding rules in Outlook for some reason.
0
 
OhmitAuthor Commented:
Dear Experts.

This is still not working!
I assume, that re-disabling the "Automatic forwarding" is only a security issue?

There is NO sign of the cause (or the problem) in the Event Viewer.
Mails just simpli disappear???

I have tried with several contacts and this seems to be an overall problem???
0
 
OhmitAuthor Commented:
OK I have some very important information here!
I have found out that this problem is only for external senders.
All users within the domain who send mail to the address is forwarded to the external address.

I think this is some kind of relaying issue!
0
 
Simon Butler (Sembee)ConsultantCommented:
Nothing has changed from the comment I made earlier - you need to look at message tracking to see what Exchange is doing with the message. If the message is going through Exchange then the problem is with the remote server, probably for the reason I gave above.

This is NOT a relaying issue, as contact forwarding is not a relaying setting, and enable automatic forwarding is for rules in Outlook and does not need to be enabled (you shouldn't allow automatic forwarding in Outlook, as users are stupid and it is just a matter of time before someone configures a loop).

Simon.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 3
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now