google home page problem - Wrong country

I recently travelled to Italy, and I logged on to my home computer in Houston Texas using gotomypc.com.  Now I am back home in Houston and I have a problem.  When I open Chrome the home page shows "https://www.google.com/" but the text on the page is Italian.  Chrome asks me if I want to translate the page to English.  I tried rebooting my computer but it did not help.  Is it in the cookies or cache files saved on the PC?
MarkVoltAsked:
Who is Participating?
 
mark_harris231Commented:
Is it just the Google page, or are other sites in Italian as well?

You might want to check your Google language setting:

Google Language
0
 
MarkVoltAuthor Commented:
I checked and Google has English as my preferred language.  I will try the link from awawada now.
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
MarkVoltAuthor Commented:
I tried the link but Google preferences for home page and search engine seem to be correct.  Nothing shows Italian.  Maybe I should un-install and then re-install chrome?
0
 
mark_harris231Commented:
Do other sites show up in Italian or just Google?

If you have another browser installed (e.g., IE or Firefox), do they display Google in English or Italian?

I don't think a re-install is necessary - just need to isolate the scope of the issue.
0
 
awawadaCommented:
First download Ccleaner
http://www.piriform.com/ccleaner/download/portable

and clean your temp files after let me know.
0
 
MarkVoltAuthor Commented:
I had trouble finding the "cog" image, all I could find was the "wrench" which did not have the same language selection option.  Somehow, I still don't know how except that I stayed on the Italian page and was looking around on it, I stumbled on the "cog" and found that it was set to "Italian", even though under the "wrench" settings it showed "English".  Seems this is a bug in Google Chrome maybe?  Anyway, thanks for the link and help, without which I would never have found the "cog" link.
0
 
awawadaCommented:
Nice that it worked. Thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.