SBS 2003 Std. DHCP Server not working

Posted on 2012-09-16
Last Modified: 2012-09-17
This box has 1 NIC.

When I inherited this box, it's SonicWALL router was the DHCP server for the network, and all the workstations had static IP addresses.

I changed all the workstations to DHCP for the IP address and DNS.

I turned off the router's DHCP server, started the server's DHCP service  and ran the server's DHCP wizard to setup the scope, options and authorize.

When I restarted one of the workstations, it did not get an IP address from the server; it just got the dreaded 169.254.x.x.

Stuff I've done trying to get it to work, although not necessarily in this order:
Delete and redo the DHCP server
Restart the DHCP service
Restart the server
Netsh int ip reset on the workstation
Netsh reset winsock on the workstation
Restart the workstation after every change

I didn't think it was necessary to rerun the CEICW. Should I have?

What have I forgotten to do or overlooked?


Question by:markperl1
    LVL 17

    Expert Comment

    Are all the other workstations getting an ip address from the dhcp server? If its only happening to 1 workstation, check the switch port that it's connected to, try connecting it to a different port.
    LVL 95

    Accepted Solution

    Have you reviewed the event logs?  SBS DHCP shuts off automatically if there's another DHCP server detected on the network.  Easy to test - unplug the server from the network at the switch (and if necessary connect it to a switch NOT connected to anything else so Windows detects a link - does DHCP stay running then?)

    Odds are SOMETHING else is trying to serve DHCP and SBS is shutting it off.  If it is another DHCP server, then there should be messages in the event logs indicating so.  And if not, more clues should still be there... so check the logs first.  ALWAYS.
    LVL 70

    Expert Comment


    Author Comment

    It was the event logs that pointed me in the right direction! I'd looked before, but hadn't scrolled down enough. The event ID was 1041 from DHCPServer. talked about DHCP not being bound to the NIC. Further research on this site led me to the correct checkbox in the DHCP Console. I found that was also necessary to run the CEICW after making the DHCP server switch.

    After switching the DHCP server over to the SBS box, and rebooting several workstations, it also became clear that some workstations were NOT getting all the correct info through DHCP. I ran out of time testing and had to switch the DHCP server back to the router for the time being.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Free Trending Threat Insights Every Day

    Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

    My previous article  ( one possible method to get SCCM 2007 installed an…
    Many admins will agree: WSUS is is a nice invention but using it on the client side when updating a newly installed computer is still time consuming as you have to do several reboots and furthermore, the procedure of installing updates, rebooting an…
    This video Micro Tutorial explains how to clone a hard drive using a commercial software product for Windows systems called Casper from Future Systems Solutions (FSS). Cloning makes an exact, complete copy of one hard disk drive (HDD) onto another d…
    With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    12 Experts available now in Live!

    Get 1:1 Help Now