• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 687
  • Last Modified:

ESXi 5 Tagging SSD drives

Hello, im having trobule with esxi tegging my SSD's as SSD drives.

heres what happened.

added ssds to server
added commands to tag ssd's as SSD on vsphere.
SSD datastore dismounted and dissapeared due to raid controller old firmware
updated firmware on controller and now SSD Datastore stays active.
SSD's previously tagged, not tagegd anymore.
tried to run the rules again, tells me rule already exists.

so in short, rule is there, but its not applying. i followed the innstructions perfectly. it worked fine on another server, which also broke the rule after upgrading to esxi 5.1 from 5.


Cant dismount/delete datastore, get error that there are "host chache files"

I had it configured before the SSD got unmounted due to the firmware.
0
Comptx
Asked:
Comptx
  • 5
  • 3
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
are you wanting to to "tag the sdd" to use host cache?
0
 
ComptxAuthor Commented:
yes
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
I would either revert to ESXi 5.0, at present many bugs are flooding in with ESXi 5.1, or re-install ESXi 5.1.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
ComptxAuthor Commented:
esxi5 is not the cause, it happened while on 5.0
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
re-install ESXi 5.0 (this SSD tagging is a "hack" after all!)
0
 
ComptxAuthor Commented:
im afraid that is not an option, these are production servers and cant be taken down at the moment :(

there has to be a way to reapply that rule again. i did it by device, maybe can apply it using another type? name, etc etc?
0
 
ComptxAuthor Commented:
solved it myself using the following commands:

esxcli storage nmp satp rule add -s VMW_SATP_LOCAL --device "deviceid" --option=enable_ssd

instead of

esxcli storage nmp satp rule add -s SATP --device "deviceid"--option=enable_ssd --force

restarted the host and now detects it as SSD.
0
 
ComptxAuthor Commented:
self solved
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now