Update  FC HBA firmware on esxi 4.1 host

Posted on 2012-09-16
Last Modified: 2012-09-18
Hi all,

Ive been given the task of updating the firmware on about 5 VM hosts running esxi4.1 in our workplace. The driver version seems to be current but some of the hosts firmware is out of date (according to vmware support).

Adapter: Emulex Corporation LPe11000 4Gb Fibre Channel Host Adapter
Driver: Emulex LightPulse Fibre Channel SCSI driver (up to date)
Installed firmware version is: 1.11A5 (US1.11A5) but need to get to: 2.82A4 (Z3F2.82A4)
Running off HP G5's

Dont know why our vmware guys didn't get this task but its been assigned to me to do so here I am.... Ive checked a few online forums but alot of the suggestions refer to esx hosts, not esxi. I'm not afraid of the CLI as I tinker with Linux OS's but vmware is a new area for me. So wondering if any experts out there can give me some sort of process I need to follow, what additional tools need to be installed, prerequisites etc - in order for the FW upgrade to take place. The test VM host seems to have all the up-to-date firmware so I'm hesitant to make sure I do it correctly as it will roll straight into a production environment...

Question by:Key2IT
    LVL 116

    Expert Comment

    by:Andrew Hancock (VMware vExpert / EE MVE)
    Use the Emulex CIM Provider plugin for VMware vCenter server, and you can download the Dynamically download and update adapter firmware and boot code (x86 BootBIOS) per fabric, per host or per VMware cluster.

    otherwise, you will need to take down the servers, and boot from a DOS flash drive or cdrom to complete the firmware updates.

    Author Comment

    Thanks for the reply.
    I downloaded the CIM zip package and installed/rebooted the host but I dont have an 'Emulex OneCommand TAB' like the picture shown on the vmware article link. I noticed there was another package on the link you sent me, the OneCommand Application Kit, but its an rpm file in which I haven't been able to run as it seems esxi doesnt use rpms. Even when I check the plug-ins menu, there's nothing listed. Ive checked under Advanced Settings > UserVar and the CIM details are all set to 1 (enabled)
    How do I get Vsphere to show the OneCommand TAB
    LVL 116

    Accepted Solution


    Author Closing Comment

    The vcenter download was what I was missing. Once I installed that and the CIM package on the hosts, I now have the TAB and the information I set out to see - without bringing down the Production Environment... Thank you for your assistance on this, much appreciated

    Featured Post

    What Is Threat Intelligence?

    Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

    Join & Write a Comment

    This article is an update and follow-up of my previous article:   Storage 101: common concepts in the IT enterprise storage This time, I expand on more frequently used storage concepts.
    When we have a dead host and we lose all connections to the ESXi, and we need to find a way to move all VMs from that dead ESXi host.
    Teach the user how to edit .vmx files to add advanced configuration options Open vSphere Web Client: Edit Settings for a VM: Choose VM Options -> Advanced: Add Configuration Parameters:
    Teach the user how to configure vSphere clusters to support the VMware FT feature Open vSphere Web Client: Verify vSphere HA is enabled: Verify netowrking for vMotion and FT Logging is in place or create it: Turn On FT for a virtual machine: Verify …

    754 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    14 Experts available now in Live!

    Get 1:1 Help Now