• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 745
  • Last Modified:

HTML5 vid in Firefox not working?

Hi there,
I have a HTML5 Vid on this page http://www.truesecrets.com.au/strange-tours-melbourne/thanks-your-link-is-on-its-way/

I have the Video in M4V, MP4, OGV, Webm formats with the following code (I removed m4v and webm as didn't work:
<video tabindex="0" controls="controls" autoplay="autoplay" height="400" width="620">
  <source src="http://d1hsg65o8vp9ls.cloudfront.net/strange-tours-melbourne/wp-content/uploads/2011/12/TSJPintro.ogv" type="video/ogg">
  <source src="http://d1hsg65o8vp9ls.cloudfront.net/strange-tours-melbourne/wp-content/uploads/2011/12/TSJPintro.mp4" type="video/mp4">
If your browser does not support the video tag, download it here 
</video>

Open in new window

However it simply doesn't play in Firefox... any ideas on how to make it work?

I used this site to convert it to OGV and WebM formats -
http://video.online-convert.com/convert-to-webm

Other Resources:
http://d1hsg65o8vp9ls.cloudfront.net/strange-tours-melbourne/wp-content/uploads/2011/12/TSJPintro.webm
http://d1hsg65o8vp9ls.cloudfront.net/strange-tours-melbourne/wp-content/uploads/2011/12/TSJPintro.m4v

Thanks
0
Craig Lambie
Asked:
Craig Lambie
  • 5
  • 3
  • 3
  • +1
1 Solution
 
David Johnson, CD, MVPOwnerCommented:
add these to your .htaccess

AddType video/ogg .ogv
AddType video/mp4 .mp4
AddType video/webm .webm
0
 
Craig LambieAuthor Commented:
This site is hosted on IIS and has all those in the MIME types already...

I am going to move to LAMP server soon, so maybe this is the solution then.... but in meantime, any other ideas?
0
 
David Johnson, CD, MVPOwnerCommented:
are the mime type in iis ??

iis standard mime types
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
Craig LambieAuthor Commented:
I have these settings in IIS, DotNetPanel -
http://screencast.com/t/daEzQDE2z
0
 
David Johnson, CD, MVPOwnerCommented:
change them from
application/ogg .ogv           -> video/ogg .ogv
application/ogg .ogg         -> video/ogg .ogg
application/webm .webm -> video/webm .webm
0
 
Craig LambieAuthor Commented:
Tried that before, but here it is again - http://screencast.com/t/yycs2e5Muqo

still no joy.... I have read something about the codec in Webm have to be really specifically set.... any ideas?
0
 
Roopesh ReddyIT AnalystCommented:
Hi,

I recently blogged about HTML 5 Videos - http://roopeshreddy.wordpress.com/2012/09/19/tools-and-tips-for-html-5-videos/

I also mentioned some Video converters which works fine and they are FREE.

Hope it helps u...
0
 
David S.Commented:
When I try to visit your page, I'm only getting a blank page. Looking at the HTTP response headers, I see it has a 500 Internal Server error.

When I try to access the .ogv file directly, it has "Content-Type: binary/octet-stream" (which is a generic mime-type, indicating that the correct one may not be properly configured on the server).
0
 
Craig LambieAuthor Commented:
Ok so this is a mystery to me.

I tried re-converting the files, and the locally hosted file plays fine in Firefox.

I then checked the IIS MIME types, and appears to be setup correctly - see screen shot

So what is the problem?
Is it maybe that the file is hosted in Cloudfront/ Amazon Web Services?
MIME.png
0
 
Roopesh ReddyIT AnalystCommented:
Hi,

It should be working fine. Did you uploaded the videos, which you have converted using the software?

Moreover, check the solution in the post - http://support.mozilla.org/en-US/questions/855497

Hope it helps u...
0
 
David S.Commented:
I'm still getting "Content-Type: binary/octet-stream" when the browser requests "TSJPintro.ogv" or "TSJPintro.webm".

You should ask the Cloudfront administrators about this.
0
 
Roopesh ReddyIT AnalystCommented:
Hi,

I think, that is the problem! Content Type is not set properly. Some where it's going wrong!

Have a word with the Domain Hoster!

Hope it helps u...
0
 
Craig LambieAuthor Commented:
Still not sure about this, but closing questions, as I have moved on.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 5
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now