[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Can not connect to server running on Amazon Cloud

Posted on 2012-09-17
11
Medium Priority
?
1,116 Views
Last Modified: 2014-11-12
I have an AWS EC2 instance running a 3rd party web server.  I can connect to the web server locally when connected via RDP.  It is running on port 8081.

After following the instructions to allow http traffic over that port i am still unable to see the web server over the web.

My instance is tied to a premade security group which allows traffic for http (80), MS SQL (1433) and RDP (3389).  I am able to connect to the machine via rdp with no issue.  I do not have any web server running on port 80 or SQL instance to test those.

I added a custom TCP rule for port 8081 to allow traffic from everywhere but still no success.

so essentially

http://localhost:8081 works fine
http://public IP:8081 does not work

Any ideas?

Thx
GL
0
Comment
Question by:gdinunzio
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 6

Expert Comment

by:MPJHorner
ID: 38406036
Has to be another firewall in the way.
Only possibly reason, do they give you another Firewall? do they not allow traffic on that port?

Have you checked the permissions on the files are available to all other that a local user?
0
 
LVL 33

Expert Comment

by:shalomc
ID: 38410214
Allow egress 8081 in the windows firewall.
There are always issues with the built in windows fw and non-microsoft services :)
0
 

Author Comment

by:gdinunzio
ID: 38410256
There is a rule allowing incoming traffic on port 8081.  No change
0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
LVL 33

Accepted Solution

by:
shalomc earned 2000 total points
ID: 38410413
fire up another EC2 instance in the same region, and see if you can connect from it to the web server via the local 10.* address.
0
 
LVL 84

Expert Comment

by:David Johnson, CD, MVP
ID: 38410504
Are you following the instructions presented @ http://cloud-computing.learningtree.com/2010/09/24/understanding-amazon-ec2-security-groups-and-firewalls/

My instance is tied to a premade security group which allows traffic for http (80), MS SQL (1433) and RDP (3389).  I am able to connect to the machine via rdp with no issue.

in the source ip of 0.0.0.0/0  did you remember the /0 ?

did you change the port in both places in the apache.config ? There are 2 locations.
0
 

Author Comment

by:gdinunzio
ID: 38410735
The security group looks correct.  The file is attached.
The instance is windows not linux.
0
 

Author Comment

by:gdinunzio
ID: 38410810
The file should be attached.
0
 
LVL 84

Expert Comment

by:David Johnson, CD, MVP
ID: 38412424
There is a rule allowing incoming traffic on port 8081.  No change

You have to modify 2 rules.. the ec2 configuration firewall AND the windows firewall
0
 

Author Comment

by:gdinunzio
ID: 38413778
Both have been modified.  8081 on the EC2 security group is set to allow incoming traffic from all ip addresses and the windows firewall has been disabled.
0
 
LVL 33

Expert Comment

by:shalomc
ID: 38414143
fire up another EC2 instance in the same region, and see if you can connect from it to the web server via the local 10.* address.
0
 

Author Closing Comment

by:gdinunzio
ID: 38521406
Another EC2 instance worked correctly.  Thanks
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Often times it's very very easy to extend a volume on a Linux instance in AWS, but impossible to shrink it. I wanted to contribute to the experts-exchange community a way of providing a procedure that works on an AWS instance. It can also be used on…
Moore’s Law has proven itself time and time again since it was first introduced. So what’s next? Will Moore’s law continue to remain relevant, or will new technology take over and bring us the next big advancement in computing?
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
When cloud platforms entered the scene, users and companies jumped on board to take advantage of the many benefits, like the ability to work and connect with company information from various locations. What many didn't foresee was the increased risk…
Suggested Courses

834 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question