[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1062
  • Last Modified:

Cannot get into my network from outside after upgrading to SuperHub

Virgin Media have recently upgraded my modem to a new faster SuperHub.

The problem that I have is that I now cannot get to my file server, webcams or website from outside my network. All of these services are running ok as I can get to them from inside without problems.

I have currently turned the SuperHub to 'modem mode' so that all routing and the like should be off.

Dyn updater indicates that my external IP address is synched to my DNS Host and I have re-booted everything many times.

I have changed nothing in my router.

I can get to the web from inside so the SuperHub is working

I am currently at a loss as to what the problem is.

Regards

Mark Preston
0
Mark Preston
Asked:
Mark Preston
  • 9
  • 6
1 Solution
 
davorinCommented:
Is the IP address on external port of your router the same as you get on this web site?
http://www.whatismyip.com/
0
 
Mark PrestonAuthor Commented:
Yes, both the router WAN IP and what's myip are the same.
0
 
davorinCommented:
The only thing that can think of, is that you could have configured rules on your router using your (old) IP address instead of your router interface. But I guess you use (now and before) dynamic assigned IP adresses...

Maybe you can try to open router management from external interface and try to access router management console from outside (internet). If it is not working in this way and it works if you directly connect a PC on external interface (set fixed IP on both devices), then I guess there is something wrong with your new modem or its configuration...
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
Mark PrestonAuthor Commented:
I have no explicit IP rules set: I don't think my router will do that (Netgear FVS 338) also backed by the fact that I know I'm on a dynamic allocation and have no idea what my IP address is or was (which I would have needed to know)
0
 
Mark PrestonAuthor Commented:
I'm making some progress that might help point the finger.

I CAN get into the system from outside

If I try

www.myurl.com:10000 - then that does take me to one of the cameras

however just

www.myurl.com no longer takes me to the website

I'm pretty certain that this means that the DNS lookup is all OK and that it's the new Hub is doing (or not doing) something with port numbers

Any ideas? It was so long ago that I set this up that I have forgotten exactly how this all works.
0
 
davorinCommented:
10000 is the port where that cam was accessible also before modem change?

Try firstly to exclude problems with your router configuration.
Set fixed IP address on external port of your router and connect to it a computer, also configured with fixed IP from the same IP range. Try to access needed services from that computer using IP address defined on router (website, webcams,...).
If it is not working, double check your routing configuration (port forwarding and maybe if you are using port 80 for management console on your router).
If it is working, then the problem is on your superhub. Try to disconnect it for a couple of seconds from mains, try to configure it again in router mode and then that settings back to modem mode. If this still does not work, I would consult your ISP technician for reseting superhub to default settings, possible firmware upgrade or modem replacement.

User manual on Virgin media for that device (I guess it is netgear vmdg480) is simply great. (i'm a little bit ironic.)
0
 
Mark PrestonAuthor Commented:
I'l look into all this again when I'm home again tonight

10000 is where the camera was before

well actually I have cameras on http://myurl.com:10000, 10001, 10002 & 10003
my router on https://myurl.com:8080
file server on https://myurl.com
etc.
I then had an Apache powered website on http://myurl.com with router port fowarding pointing incoming requests to the correct internal IP address

The major problem seems to be that I cannot now get to the website. I guess that the SuperHub is either blocking that or there is a port conflict?
0
 
davorinCommented:
ok, I'll wait for your findings.
0
 
Mark PrestonAuthor Commented:
I started looking into this this a.m. - started to get confused as to what I was trying to achieve... and then realised the following:

The only thing that has changed is the modem and it's setup at Virgin
I can still access everything OK internally

So... if I can still get to everything OK internally AND I haven't changed anything in the router then the router config must be fine.

I'm suddenly wondering if Virgin are blocking these ports now?
0
 
Mark PrestonAuthor Commented:
Apparently Virgin don't block ports - or so the consensus is.

I'm still a bit mystified about your instructions: Connect a PC to the internet port of the router?..and set the IP addresses to what?

And then run http://192.168.1.22 (web server)
or http://192.168.1.200 (camera)?

no..surely not..that's missing the point

it should be http://192.168.1.1 (router IP address) and that should send it to 192.168.1.22:80
and http://192.168.1.1:10000 should send it to the camera on 192.168.1.200:80

Is that right?

It's so long ago that I set this up that I forget how it all works.

Thanks

Mark
0
 
davorinCommented:
On your router you have some LAN (internal network) ports on which are connected your computers, cameras,... On that side router has configured 192.168.1.1 IP address.
Then have one WAN (internet) port which gets IP address dynamically from your ISP provider. This port disconnect from ISP modem and connect it to one computer you will use for run tests. (not the one you have web server on.)
Configure that (WAN) port of the router with some static IP (let say 192.168.2.1/255.255.255.0) and your testing PC with 192.168.2.2/255.255.255.0.
Then try from testing PC to access http://192.168.2.1:10000 for camera, http://192.168.2.1 for web site,...
Test everything.
In this way you test if your router is correctly configured and is working as it should. If it is working, then the blame is on ISP equipment. At the end revert the settings back.
0
 
Mark PrestonAuthor Commented:
OK got that - thanks.

I'll try that first chance I get - probably be Monday now though..
0
 
Mark PrestonAuthor Commented:
I tried EXACTLY as you outlined and I still cannot get through the router. Which I must say as 100% strange as nothing in the router has changed at all. However I understand what the above test is doing and have to concur that your conclusion is correct.

So.. although I'm not up and running again - the problem is sitting right in front of me - I just have to work at figuring it out... which is a different problem.

Thanks
0
 
davorinCommented:
Thanks.
I would start that with checking inbound service rules:

http://www.downloads.netgear.com/files/FVS338_RM_28Jan2010.pdf

Look at pages 4-7, 4-11...
0
 
Mark PrestonAuthor Commented:
What puzzles me though is that it was all working great for the last 3 years and only happened when I changed the modem for the new superhub. I wish I could go back to the old modem and hang the speed increase!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 9
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now