Android requires compiler compliance level 5.0 or 6.0.

I am trying to get all the AndEngine code working. I just installed AndEngine (and it builds correctly) and now I have used git to get an extension, but get this error when it builds:

AndEngineTMXTiledMapExtension] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.

I did the Fix Project Properties as suggested but it fixed nothing.
Who is Participating?
allelopathAuthor Commented:
Oh, I got thrown off by the message. If it had said " compliance level 1.5 or 1.6", then I would have understood it.
Yup, well, all these little things are easy to miss when you're close up to your app. ;)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.