Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Remote desktop error

Posted on 2012-09-18
4
Medium Priority
?
2,280 Views
Last Modified: 2012-09-25
I recently installed some CAL's on our server 2008 R2 I am getting an error on 2 of the 12 computers that connect remotely.

"Remote desktop disconnected- Because of a security error, the client could not connect to the remote computer. Verify that you are logged in to the network and then try again."

The 2 computers receiving this error are running windows XP
I can log in with their user names from any other computer

http://technet.microsoft.com/en-us/library/cc756826(v=ws.10).aspx#BKMK_Because

I found this article talking about the same error message for server 2000 and 2003.
I have not yet tried to see if the fix applies to server 2008 R2 as well; and am hesitant to do so as the error only appears on 2 of the computers that are trying to connect.

Any thoughts would be appreciated
0
Comment
Question by:siggy9
  • 2
  • 2
4 Comments
 
LVL 17

Assisted Solution

by:Spike99
Spike99 earned 1500 total points
ID: 38412325
Do those XP systems have RDP 7.0 installed?
    http://support.microsoft.com/kb/969084

If they do, then they need to enable a feature called CredSSP in order to connect to a 2008 server.

See this KB article for a MS "Fix It" tool to enable CredSSP on Windows XP systems (a reboot is required after applying this fix):
    http://support.microsoft.com/kb/951608

I hope this helps.

Alicia
0
 

Accepted Solution

by:
siggy9 earned 0 total points
ID: 38418235
Thanks that did help. In the process of trying to implement your fix I found that the 2 computers affected did not have service pack 3 Installed. As soon as I installed SP3 it connected right up. Thank you.
0
 
LVL 17

Expert Comment

by:Spike99
ID: 38418737
Good catch: I should have thought of that!  SP3 updates RDP to v. 6.1. If they had RDP 5.0 or 6.0 (which I think is what's included in SP2), I think that would also cause issues connecting to 2008.  6.1 added some security enhancements in addition to the ability to connect to a TSGateway server through a firewall.

I'll have to keep that in mind and thanks for the points!
0
 

Author Closing Comment

by:siggy9
ID: 38431896
Actual solution came for investigating a lead from another experts comment
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
Measuring Server's processing rate with a simple powershell command. The differences in processing rate also was recorded in different use-cases, when a server in free and busy states.
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

572 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question