Server will not respond in Xen Server

We have a Xen server running 3 virtual servers.  One is a domain controller, a SQL server and a file server. All running Server 2008 R2 Enterprise.

We went to install Storage craft on the SQL server and we rebooted it and it took for ever to come up.  It wouldn't come up so we rebooted it from the Xen Center.  It takes almost 20 minutes for it to boot into windows and when it finally gets to a desktop it will be just the desktop background but no desktop.

We are unable to ping this server once its booted up.  We should be able to ping it when its starting to come up but nothing.

One engineer thinks he saw that TCPv6 was unchecked in network properties. We can only access this server from the Xen Center on the domain controller.

Would this be the cause?  We are trying to reboot it and check.  Its just really slow.  Remember this is a virtual server.
maximus7569Asked:
Who is Participating?
 
maximus7569Connect With a Mentor Author Commented:
Please close this question.
0
 
barrykflCommented:
Did u check citrix suport web site and update the firmware of Controller / Hardware.
0
 
Ayman BakrSenior ConsultantCommented:
Check the network tab of the VM in XenCenter. Does it show its MAC address? Does it show the IP address?

Do you have a backup or snapshot for the previous state of the VM? If you can't go into the VM to check the network settings for troubleshooting, then your last option would be to restore from a backup or snapshot.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Tony JLead Technical ArchitectCommented:
This does somewhat suggest that the software installation caused a problem.

If you reboot into safe mode is it any quicker?

Anything in the event logs?

Did the software install any services? If so, it might pay to disable them and reboot - see if it's any quicker.

IPV6 shouldn't be disabled unless there's an absolute requirement for it to be - I've seen this quite frequently lately on here where it's causing more issues than the perception of disabling it are fixing. I've only come across one backup application that requires IPV6 to be disabled so far.
0
 
maximus7569Author Commented:
We were able to uninstall the software and reboot but it still runs slow.  IPv6 is checked.   There is a IP address and mac address on the network tab in Xen center.  I have logged into the server but it has locked up.  Even in safe mode is the server really slow.  I am really unable to do anything in here.  We don't have a backup as the server is about a month old.  We were install Shadow Protect on here in order to backup.  The other 2 servers had no problems with the Shadow protect software.  This one is running SQL is the only difference.  Any other thoughts?
0
 
Tony JLead Technical ArchitectCommented:
Have you checked performance monitor? See if there's a rogue process at all?

Checked the performance from a Xen perspective?

Was the software the only thing that changed?
0
 
maximus7569Author Commented:
Well I can even do anything in the server itself to check. Even safemode it locks up. I noticed in Xen Server console ,not Xen center,  under VMs running on this host, it shows high CPU usage. The software was the only thing that changed.  It was running fine before we installed Shadow Protect.

Here are some snapshots.  What do you think?
Performance-Monitor.PNG
CPU.PNG
0
 
Tony JLead Technical ArchitectCommented:
Looking at the perfomance monitor it does look like you're experiencing some peaks with CPU.

It may be worthwhile checking which process is ramping up.

I realise you've uninstalled the software but has it possibly left something behind - either a service or a startup item?

If you fire up MSCONFIG it's a great way to see startup items in the registry.
0
 
maximus7569Author Commented:
Tony1044, Well this is weird.  The server was stable enough in order for me to install Xen tools.  I noticed that they had not been installed on the server.  It's weird that it was stable enough for me to install it and I rebooted the server.  The server came up and I noticed on the server with Xen Center loaded, I had a continuous ping running, and it was getting full reply's.  I was able to log into the server and it is stable now.   I looked at the network card and noticed the DNS was wrong in there.  I changed it back to what it should be.
So now I don't know what fixed it and what caused it.  I am hesitant to say that just installing the Xen tools fixed it, but I do know its hard to work in the console if they are not installed.  Its really choppy to work in console in Xen center if they are not installed.  You still think Shadow Protect caused it?
0
 
Tony JLead Technical ArchitectCommented:
Hmm - certainly Xen tools will help performance but I can't imagine it'd be to that extent.

It really sounds like a combination:

DNS, lack of tools and possibly something in Shadow Protect - I'm not a big believer in coincidence so it's hard to rule it out.

The problem you have, of course, is given it's a SQL server it makes snapshots and the like almost useless.

I guess at some point you are going to have to reinstall the software.

Far from an ideal solution, I know.

The problem is of course that any of those things could have contributed: wrong DNS means slow network resolutions and potentially slow logins / startup etc; lack of Xen tools means potentially bottlenecked network and lower performing CPU / graphics etc; and then finally the software could have been the straw that broke the camels back as it were.

If performance better now too in perfmon and from the console?
0
 
maximus7569Author Commented:
I am fixing to get perfmon running on the server and I will let you know.  But so far, server is really stable like it was before SP was installed.
0
 
maximus7569Author Commented:
Please close this question as this server is no longer in use.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.