[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Internet Explorer will not connect

Posted on 2012-09-18
21
Medium Priority
?
353 Views
Last Modified: 2012-10-23
I am working on a machine that was infected. I ran ComboFix, MalwareBytes, and CCleaner, and all seemed well. No residual issues, except, Internet Explorer will not connect to any sites.

Google Chrome and Firefox open and run with no issues. I have reset all settings for IE. During the reset, I was able to connect once to google. After closing and reopening, IE stops connecting. Also, within IE, when accessing the settings menu, all of the options are grayed out. Once I open IE and am prompted to turn on add-ons, the menu is available, but, still cannot connect.

I have reverted back to the previous version of IE, but, it just simply stalls when opening.

The problem occurs with virus protection on and off.
0
Comment
Question by:mjgreenley
  • 10
  • 5
  • 4
19 Comments
 
LVL 3

Expert Comment

by:AliQahtani
ID: 38412444
can you try the link below
http://support.microsoft.com/kb/967897#gm4
go to the step I can’t access any websites
0
 
LVL 1

Author Comment

by:mjgreenley
ID: 38412456
Thanks for the link AliQahtani: I ran the "fix it" option but the result was that there "were no issue detected, and no changes made."

So, the problem continues.
0
 
LVL 3

Expert Comment

by:AliQahtani
ID: 38412494
Can you do the steps below:

1- Go to C:\Windows\system32\drivers\etc folder.

2- Right click on the host file.

3- Click on "Open with" in the context menu. From the displayed software choose "Notepad" to open the "host" file with Notepad. If there is any line starting without # contains the website address, which you are unable to access, then go to next step or skip to next method.

4- Copy everything from that host file except those lines started without # and close the file. It's recommended to paste copied content in temporary text document. This content will be needed later.

5- Delete the host file.

6- Right click inside "etc" folder and go to New ¿ Text Document. Type "host" as the file name.

7- Open the newly created host text file and paste the content you have copied from previous "host" file. Click on File ¿ Save or Ctrl+S .

8- Click on Tools ¿ Folder Option for Windows XP, Vista and Organise ¿ Folder Option for Windows 7 users in "etc" folder window.

9- Go to "View" tab in Folder Options window. Select the option "Show hidden files" and unselect the option "Hide extensions for known file types", then click on OK.

10- Click on "host.txt" and press F2 button in your keyboard to rename. Change its name from "host.txt" to "host" and press Enter. It'll show you a warning asking to do you want to change the file extension, click on Yes.

11- Right click on "host" file. Go to Properties from context menu. Select Read-only and Hidden option under General tab and click on OK.

12- Try to open that website in your web browser.

good luck
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 3

Expert Comment

by:AliQahtani
ID: 38412512
0
 
LVL 1

Author Comment

by:mjgreenley
ID: 38412535
These are the only contents from the host file, does this make sense?:


# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#      127.0.0.1       localhost
#      ::1             localhost
0
 
LVL 3

Expert Comment

by:AliQahtani
ID: 38412568
can you try to copy the one below and past it the your host file.


# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost
0
 
LVL 1

Author Comment

by:mjgreenley
ID: 38412581
I will try that right now. Interestingly enough, I typed Internet Explorer into the start menu search and opened up Internet Explorer (no add ons) and it opened right up and connected with no issue. So...it appears that maybe there is an add on that is restricting access.

The only two add-ons in the list that look suspicious to me are "Inbox Toolbar" from inbox.com and "IEHlprObj Class" from iWin Inc.  Can't delete either one. Ran Hijackthis and can't remove it from there either.
0
 
LVL 1

Author Comment

by:mjgreenley
ID: 38412593
Do I name is host or hosts? Current file is named hosts
0
 
LVL 3

Expert Comment

by:AliQahtani
ID: 38412723
it is hosts
0
 
LVL 1

Author Comment

by:mjgreenley
ID: 38413515
Ok, I'll try that. Any idea on how to get rid of those BHO's?
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 38414432
mjgreenley--You should be able to delete or at least disable those BHO's from IE Tools|Manage Add-ons.  Highlight the unwanted BHO and click Disable in the right bottom.

If that does not help, you probably have another BHO that is causing the problem.  Disable all per the above and then enable one by one until the problem returns.

Are you using a Proxy by any chance?
0
 
LVL 1

Author Comment

by:mjgreenley
ID: 38414810
jcimarron: I can open IE using the IE(no add-ons) option from the start menu, however, I cannot use IE without the non add-ons option. So, once IE opens it stalls. I cannot access tools or option or any other feature...it simply opens up in a "not responding" state.
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 38415105
mjgreenley--From your post http:#a38412581 I understand you can access the Manage Add-ons window.  All the Add-ons (showing as Enabled (strangely) will be there for you to Disable.
0
 
LVL 1

Author Comment

by:mjgreenley
ID: 38415917
jcimarron: I was able to access the manage add-ons screen through the IE no add-ons browser. I disabled every add on, but the problem did not go away. However, I did find something new...If I wait long enough, say 2 minutes...IE will connect and display the home page. If I close out of IE and reopen right away it works fine. If I close it and wait a minute, then try to reopen, it will just sit there...but will connect after a 2 minute delay.

AliQahtani: I replaced the hosts file with the info that you provided...no change.
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 38415942
mjgreenley--Are you using a Proxy server?
0
 
LVL 1

Author Comment

by:mjgreenley
ID: 38416105
No proxy server
0
 
LVL 50

Accepted Solution

by:
jcimarron earned 2000 total points
ID: 38418620
mjgreenley--Several ideas here
http://answers.microsoft.com/en-us/ie/forum/ie8-windows_xp/it-takes-up-to-5-minutes-before-internet-explorer/c345b9fc-85b3-4894-8ac1-f1adf69e0ae4

http://support.microsoft.com/mats/ie_performance_and_safety/

If no help, something (program) is running at the same time IE is trying to load.  Task Manager might help find it.  
Or possibly Process Explorer
http://technet.microsoft.com/en-us/sysinternals/bb896653
0
 
LVL 1

Author Comment

by:mjgreenley
ID: 38419141
Thanks jcimarron, I'll try that and get back to you.
0
 
LVL 1

Author Comment

by:mjgreenley
ID: 38420373
jcimarron: That fist option for the Fix-it solution seemed to work. I'm going to reboot a couple of times to make sure, but so far it's been responding perfectly! Thanks for all your help!

AliQahtani: Thanks for all of your support and help with this issue.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In threads here at EE, each comment has a unique Identifier (ID). It is easy to get the full path for an ID via the right-click context menu. However, we often want to post a short link within a thread rather than the full link. This article shows a…
Following on from our article on "The Murky World of Consent and opt in", we thought we would issue some helpful guidance, not only on consent itself but knowing what information you are capturing, what you are doing with this data and how you can p…
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
Suggested Courses
Course of the Month20 days, 7 hours left to enroll

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question