SharePoint Create List Item Removes .00 Decimals

Posted on 2012-09-19
Last Modified: 2012-09-25

I have created a Doc Library in SPD 2010 and created a Document Content type which I have then editied the template for so I can push the fields through using Words Document Properties Quick Parts.

I have then created an Approval Workflow which, when Approved, creates a document in the Doc Library and sets the Doc Properties in the doc to the same as the form fields.

Some of the fields are used to hold financial figures. Most of these have been set as a Currency field with 2 decimal points but one of them has been set as a Single Line of Text field - as it's held within a Repaeting Table.

If I set the figues as (for example) 100.26 it pushes this through to the Word doc fine. If I set it as 100.00 it will be displayed in Word as just 100.

I'm guessing this must be some kind of AutoCorrect when creating the Doc and setting the field but I can't figure out how to change this.

Any ideas?

Question by:Tugsol
    LVL 6

    Expert Comment

    check how it's stored in sharepoint... maybe word is being smart, reformatting on its' own...

    Author Comment

    Hi livanescu,

    When you say "check how it's stored in sharepoint" I'll take it you mean on the Library it's creating the Document in?

    In the Library it looks to be grand. I've tried playing around with the List Columns and changing them from Currency to Single/Multiple Lines of Text and on the Library the figures appear fine and have the .00 at the end of the figures.

    When I open the Word doc though it has dropped the .00 off the figures. I can manually type these in in Word and they stay so I don't think it's an AutoCorrect option in word.

    Is there something I could maybe set or change in the Doc Template to prevent this from happening?

    I thought it could be to do with the SharePoint server default for decimals (which is Auto) when it writes the fields to the doc. To test this theory any idea where I can change the server default for decimals - top level site/Central Admin etc?


    Accepted Solution

    Ok I have managed to use a workaround.

    I have changed all of the fields in my Form from Currency to Text fields.

    The one field I had which was passwed through as a Text field in the Library was a Currency field in InfoPath. Now they are all text fields I have to manually type the .00 after the figure but it at least creates it in the Word Doc now.

    Author Closing Comment

    Answered my question.

    Featured Post

    How to run any project with ease

    Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
    - Combine task lists, docs, spreadsheets, and chat in one
    - View and edit from mobile/offline
    - Cut down on emails

    Join & Write a Comment

    Shortcuts in Word Just the other day I had a training for Microsoft and they wanted me to show how well the new Windows and Office behaved on a touch device, which by the way is great, but it was only then that I realized that using keyboard shortc…
    These days socially coordinated efforts have turned into a critical requirement for enterprises.
    Learn how to make your own table of contents in Microsoft Word using paragraph styles and the automatic table of contents tool. We'll be using the paragraph styles in Word’s Home toolbar to help you create a table of contents. Type out your initial …
    Office 365 is currently available in five editions. Three of them are for business use: Office 365 Business Essentials, Office 365 Business, and Office 365 Business Premium. Two of them are for home/personal use: Office 365 Home and Office 365 Perso…

    728 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now