• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1245
  • Last Modified:

RPC/HTTP connection to Exchange 2003 fails

I'm running an old Small Business Server 2003.
All smartphone users is already able to connect to their mailbox externally.

Now I am asked to enable the RPC/HTTP function to be able to receive mail in EXTERNALLY connected Outlook clients.

When I use the TESTEXCHANGECONNECTIVITY.COM site I get an error appearantly from the IIS saying:

----------------------------------------------------------------------------------------------------------------------------
Testing HTTP Authentication Methods for URL https://remote.domain.dk/rpc/rpcproxy.dll?server01.domain.net:6002.
The HTTP authentication test failed.

Additional Details

An HTTP 403 forbidden response was received. The response appears to have come from IIS6. Body of the response: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<HTML><HEAD><TITLE>You are not authorized to view this page</TITLE>
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=Windows-1252">
<STYLE type="text/css">
 BODY { font: 8pt/12pt verdana }
 H1 { font: 13pt/15pt verdana }
 H2 { font: 8pt/12pt verdana }
 A:link { color: red }
 A:visited { color: maroon }
</STYLE>
</HEAD><BODY><TABLE width=500 border=0 cellspacing=10><TR><TD>

<h1>You are not authorized to view this page</h1>
The Web server you are attempting to reach has a list of IP addresses that are not allowed to access the Web site, and the IP address of your browsing computer is on this list.
<hr>
<p>Please try the following:</p>
<ul>
<li>Contact the Web site administrator if you believe you should be able to view this directory or page.</li>
</ul>
<h2>HTTP Error 403.6 - Forbidden: IP address of the client has been rejected.<br>Internet Information Services (IIS)</h2>
<hr>
<p>Technical Information (for support personnel)</p>
<ul>
<li>Go to <a href="http://go.microsoft.com/fwlink/?linkid=8180">Microsoft Product Support Services</a> and perform a title search for the words <b>HTTP</b> and <b>403</b>.</li>
<li>Open <b>IIS Help</b>, which is accessible in IIS Manager (inetmgr),
 and search for topics titled <b>About Security</b>, <b>Limiting Access by IP Address</b>, <b>IP Address Access Restrictions</b>, and <b>About Custom Error Messages</b>.</li>
</ul>

</TD></TR></TABLE></BODY></HTML>
-----------------------------------------------------------------------------------------------------------------------------

Can anyone point me in the right direction?
0
Ohmit
Asked:
Ohmit
1 Solution
 
Alan HardistyCommented:
As per the error:

HTTP Error 403.6 - Forbidden: IP address of the client has been rejected

Please check the Exchange Virtual Directory and the RPC Virtual Directory and remove any IP Restrictions from them (using IIS Manager).

Also make sure you have Basic and Integrated Windows Authentication enabled on the RPC Virtual Directory.  if you make any changes run IISRESET from a command prompt, then re-test.

Alan
0
 
Simon Butler (Sembee)ConsultantCommented:
Have you enabled the feature in SBS?
You need to run the Connect to the Internet and Configure email wizard and choose to enable Outlook over the Internet. Wait about 15 minutes afterwards.

Simon.
0
 
OhmitAuthor Commented:
Feature is enabled.

How do I check for ip restrictions?
0
Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
Alan HardistyCommented:
Open up IIS manager and expand your Default Website, then right-click on the RPC and Exchange virtual Directories (one at a time) and check on the Directory Security Tab, then on the 'IP Address and domain name restrictions' edit button.

This should be set to 'Granted Access'.

If you have to make a change, click OK and then open up a command prompt and run iisreset.  Then test again.
0
 
PartnerTekCommented:
alanhardisty's suggestion seems to be the solution.  I had the same problem, but on the microsoft-active-sync directory.  Removing the IP restrictions and resetting IIS fixed it right up.

Ohmit, you should also remove the link to your server from this thread.
0
 
Alan HardistyCommented:
Sorry - but have you chosen the wrong answer here?
0
 
OhmitAuthor Commented:
well Im affraid no.
See the customer told me that he has ran the INTERNET AND EMAIL CONFIGURATION WIZARD but it showed out that he has NOT enabled OWA.
When I re-ran this enabling OWA everything worked out.
I am sorry and I know that your answer was based of wrong information from me.
0
 
Alan HardistyCommented:
No problems - just wanted to make sure as it appeared that it might be.

Either way - glad it is sorted.

Alan
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now