?
Solved

Can't Configure SNMP Traps on ESXi 5.1

Posted on 2012-09-19
6
Medium Priority
?
2,332 Views
Last Modified: 2012-09-23
I am unable to configure SNMP communities on my ESXi 5.1 server via the shell console. When I attempt to run the folowing comand; vicfg-snmp.pl --server hostname --username username --password password --show, I get an error message: "vicfg is not a valid command"

Can anybody assist?
0
Comment
Question by:GR JN
  • 3
  • 2
5 Comments
 
LVL 124
ID: 38413627
The vicfg-snmp.pl command is to be used from the Remote CLI or vSphere CLI, not at the ESXi 5.1 console.

Use the vicfg-snmp.pl command from the Remote CLI or vSphere CLI to enable the SNMP agent and configure trap destinations.

see here

http://kb.vmware.com/kb/1008065

download vCLI here

http://www.vmware.com/support/developer/vcli/
0
 

Author Comment

by:GR JN
ID: 38413832
After doing this from the remote CLI, I am now getting the below message:

C:\Program Files (x86)\VMware\VMware vSphere CLI\bin>vicfg-snmp.pl --drs-vsphere
02
Unknown option: drs-vsphere02
For a summary of command usage, type 'C:\Program Files (x86)\VMware\VMware vSphe
re CLI\bin\vicfg-snmp.pl --help'.
For documentation, type 'perldoc C:\Program Files (x86)\VMware\VMware vSphere CL
I\bin\vicfg-snmp.pl'.

It looks like it is not able to see the remote esxi server I am tryiong to enable SNMP on. I have also tried via IP address.
0
 
LVL 124

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 2000 total points
ID: 38413849
the command is:-

vicfg-snmp.pl --server hostname --username username --password password --enable

vicfg-snmp.pl --server drs-vsphere --username username --password password --enable

make sure that drs-vsphere can be resolved
0
 

Author Comment

by:GR JN
ID: 38414374
I've requested that this question be closed as follows:

Accepted answer: 0 points for Narvaezj's comment #a38413832
Assisted answer: 500 points for hanccocka's comment #a38413849

for the following reason:

.jk
0
 
LVL 124
ID: 38414375
Just been fussy here, but http:#a38413832 is not the Accepted Solution.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
In this article I will be showing you how to subnet the easiest way possible for IPv4 (Internet Protocol version 4). This article does not cover IPv6. Keep in mind that subnetting requires lots of practice and time.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question