• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1740
  • Last Modified:

Citrix concurrent application

Hello,
Some users in my organization has a problem with login to terminal server with citrix XenApp 6.0

They get this message:
The Citrix server has reached its concurrent application limit for this application. Please contact your system administrator.

Normally when this occurs, I just log off the active or disconnected user from the terminal server and the problem is solved.

But the problem now is that in this case, the user has no active session on any terminal servers.  I also checked the processes to se if a single process for the problem user is still hanging on, but there are no sessions and no processes for the user.

I found this hotfix, but this only fixes the error message.  Not the problem. (http://support.citrix.com/article/CTX131647)

Sorry for my bad English here.  I appreciate every advice I can get.

Please se Attached image
error-message.png
0
Thomas-Norway
Asked:
Thomas-Norway
6 Solutions
 
Vijaya Reddy Pinnapa ReddyCommented:
Configure Idle and Disconnected timeout settings.
http://support.citrix.com/article/CTX127318
0
 
Thomas-NorwayAuthor Commented:
More facts:
There is two terminalservers.

If i go to citrix delivery service console and uncheck "allow only one instance of application per user" the user is able to login (Se att. fig.)

So I believe that there is something hanging on to the servers.  But there is no processes for the user as i can see.
limits.png
0
 
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
Have you checked if your users are not logged at any other CTX server in the same farm?

How many servers are there in that farm? What is the patch level of your XenApp?
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Thomas-NorwayAuthor Commented:
Thank you for your reply.

There is a lot of servers in the farm(over 100) but there is only two terminalservers for this application. The users has no logon rights on any of the other servers, but just in case i still checked.
I have checked all servres in the farm for this users, and they are not logged on any other server in this farm.

Se version and installed hotfixes in the attachements.
hotfixes.png
version.png
0
 
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
Try if someone has logged in via RDP. Also check if the application is running on the server by using Task manager (taskmgr.exe)

And if no one else is logged in, then reboot it once and see.

BTW how often do you reboot these servers?
0
 
Thomas-NorwayAuthor Commented:
Thank you for your reply npsingh123

The citrix application is remote desktop

I checked all processes on all the 108 servers in the farm.
No processes and no session for this users.  I uses tsadmin from 2003 and connected to all the servers and sorted the processes on username.

They restart every 4. day.

I believe that if i reboot the user will be able to log inn, but then i dont find the source of the problem. I will try to reboot later today when there is fewer users loged in.
0
 
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
Lets see what other experts suggest.
0
 
Thomas-NorwayAuthor Commented:
npsingh123:  Thank you
0
 
Ayman BakrSenior ConsultantCommented:
I happened to have faced this with a few of our users. When I go and kill the session from the delivery console the user still faces the same issue. Looking at the server the processes for that user have all gone already. You then assume that the user should have already got logged off since i killed the session and that the citrix ICA client, wfcrun32.exe should end automatically. But, although this should be the case, I discovered that the wfcrun32.exe is still running in the user's PC and that the citrix applications are still showing on the user's task manager!!!

The way I tackled this problem is either to terminate the wfcrun32.exe process from the user's task manager or end the task for all the hanging Citrix applications existing on the user's task manager. Note that I am saying the user's task manager not the server task manager as the ICA client is hanging not any processes on the server.
0
 
CoralonCommented:
The error message is pretty specific.  The Citrix server has reached its concurrent application limit for this application.

Make sure there aren't more users accessing the application.  I've seen scenarios where only a handful of people were supposed to use a specific application, but other users were able to connect and hit the application limit.  

Another possible cause might be a full load evaluator on the application itself?  (I never use load evaluators on apps, other than scheduling).

Coralon
0
 
Thomas-NorwayAuthor Commented:
Hello.  Thank you very mutch for all the comments.
The problem was solved with a new citrix client.

thanks to all!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now