• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 435
  • Last Modified:

IIS default.aspx

Hello..

I got a strange issue on a IIS Site
I'm unable to browse to my website using http://testsite.domain.local 
But if i use http://testsite.domain.local/default.aspx my website shows with no problems.

On the inetpub website folder the IIS apppool account is added with modify permissions. (IIS APPPOOL\WebsiteAppPool

If i add everyone to the inetpub website folder the website shows using http://testsite.domain.local

Any suggestions?
0
Ball_Group
Asked:
Ball_Group
  • 3
  • 3
1 Solution
 
mvdeveloperCommented:
Sorry, please ignore. Reading too quickly.
0
 
mvdeveloperCommented:
Is the default.aspx the first document in your Default Document list for that site? Could it be trying to serve something else in its place if it thinks the script is not executable?
0
 
Ball_GroupAuthor Commented:
Is the default.aspx the first document in your Default Document list for that site?
Yes - its the first document.

Could it be trying to serve something else in its place if it thinks the script is not executable?
Not that i know of. But weird though, if i add everyone permissions to the website folder, everything Works?
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
mvdeveloperCommented:
What user is that apppool running under? (go to Advanced Settings).
You may need to explicitly grant folder permissions for that user or try creating a new apppool with different credentials.
0
 
Ball_GroupAuthor Commented:
Hmm, i added the iusr on the root folder to my website with read, read&execute, list folder contents. And now it Works.

Any suggestions why?
0
 
fakouaCommented:
If you are able to go to http://testsite.domain.local/default.aspx with no problem and your default document is default.aspx. so maybe your are getting the default.aspx form your local cache from previous working configuration.

In both way try Ctrl F5 or clear your cache before testing.
What is your IIS Version?
0
 
Ball_GroupAuthor Commented:
It solved the problem
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now