Connecting to local drives using terminal server.

I login to my PC locally and then connect to my terminal server via MSTSC using domain credentials.

I want to be able to use my USB stick I have plugged into my local machine on the terminal server. I have tried to add 'disk drives' within the remote desktop options but when logged on to the TS I cannot see the USB stick.

Can someone please help me to figure out a way to use my locally attached USB during my terminal server session?
Kimba123Asked:
Who is Participating?
 
ZabagaRCommented:
Does you local C:\ drive show as a mapped drive on the terminal server? or do no local drives, including USB stick show? Check terminal server configuration. RDP-TCP properties. On the "client settings" tab make sure the check box to disable drive mappings is NOT checked. Is your terminal server 2003 or 2008? In 2008 there's also a box for plug-and-play device mapping. So if 2008, check that too.
0
 
serchlopCommented:
Maybe the restriction to connect drives to your terminal server is configured at the server. That is because you can not map the drive.

Another way is to share your usb drive in your computer, then connect in terminal to your computer share and map the usb drive.

To share your usb drive, right click in the usb drive, properties, share and there you can share your usb drive.

Then in terminal open windows explorer or run windows and type

\\computername\sharename
0
 
Kimba123Author Commented:
The mapping option is a good workaround but I'd preferably want to edit group policy on the TS to allow the automatic mapping of the local drives each time the user logs on the the server.

Which group policy setting applies to this?
0
 
Kimba123Author Commented:
Many thanks for all the replies.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.