• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1579
  • Last Modified:

Internet Explorer 9 Hangs in Win7

Sometimes I just hate Windows - so much wasted time trying to figure out all the weirdness. Sorry had to get that off my chest.

The problem: I have a brand new, just out of the box Acer Veriton desktop PC. This is a company machine and I joined it to the domain first thing and proceeded to do Win updates and install Office and most of the basic, normal things. The computer is going to a new branch location/user and at first I did not know who this user would be - but, who cares? Should not matter. Once I determined the user who would be using the machine I signed on as that person (domain\user) to finish the set up specific to this person. What I am finding is that IE 9 (pre-installed from Acer) will not run correctly. The browser opens but it just hangs, and for the most part the circle thing just spins. I added the user to the local (machine) admin group - this did not help. I installed Firefox and it works beautifully. I found out how to uninstall IE 9 - it took it back to 8, and I reinstalled 9 - same problem. If I right click on the IE icon and run as administrator it works fine, but I don't want the user to have to do that every time. I also can set it to always run as administrator but then the user has to confirm this every time it starts. What is the point in being able to run IE - without explicitly stating - run as administrator - when it will not do anything but hang?? This makes no sense to me - IE 9 should just work normally for this user without spending all this time on trying to resolve this BS issue.  

I could just go with FF but unfortunately I have found that there are times when IE may be necessary for certain sites. And really I see no good reason for IE not to work.
0
Razorking
Asked:
Razorking
1 Solution
 
Charlie2012Commented:
This is usually an issue with add-ons. You can try this below. If this works I believe you can disable add-ons via group policy so you do not have to do this with all machines.

Changing the Add-ons Mode

Click Start
Type in “iexplorer.exe-extoff”
Press Enter
This opens Internet Explorer in Add-ons mode. If you do not receive any error messages during this step you can go ahead and disable the add-ons by taking the next steps.

Open Internet Explorer.
Click Tools on the right hand corner.
Click Manage add-ons.
Click on the Show drop down menu and select all add ons.
Select the add–ons by using the check marks
Click Disable in the information window.
Exit the program.
Restart Internet Explorer.
If changing the add on mode does not resolve the issue proceed with resetting the Internet Explorer Settings.

Reset Internet Explorer Settings

Click Start.
In the Start Search Box type in “inetcpl.cpl”.
Press Enter.
When the Internet Options dialog box appears click on the Advanced tab.
Click Reset under the Resent Internet Explorer settings.
Click Reset again.
Close the program when the settings have been reset.
Restart your computer.
0
 
rbudjCommented:
If it is hanging, you should review the error logs. This may help to track down the problem. You could also just turn off User Account Control and set the shortcut to run as admin to prevent having to confirm it every time.
0
 
RazorkingAuthor Commented:
Good enough - I had already tried resetting Internet Explorer Setting but I had not messed around enough with the add on - I disabled them all and it works fine - so I am leaving it at that.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now