SPS 2010- Cannot View Custom column in another Library

In SPS 2010, I have the following:

2 Document libraries (Approval and Approved) In the Same site
2 Custom Columns : Approved Manager, Invoice Amount
1 Workflow that:
    a.) writes the current user into a field called approved Manager
    b.) copies the file over to the Approved Documents
    c.) deletes it from the Approval library

Problem:
The only field that gets copied over with the file is the invoice amount. Approved Manager does not get copied over (A single text item), nor does some other columns that I tried to test.

How do I view the data that was inputted by the user when they uploaded the file in another document library?

Thanks
BKennedy2008Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

svetayeCommented:
Hello,
The issue can happened if the Approved Manager column in the first library is no the same column in the second library.
You must ensure that the columns have the same settings, so I can suggest you to create a Site Column named Approved Manager and add it to your source and target libraries.

One more thing you can do to check the process : log to history the  Approved Manager value just after you have updated it in the source item and don't delete the item after the copy, just to be sure that the value of the Approved Manager really exists when you try to copy the item. It can be some issue with the filed type as well.

I hope it will help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BKennedy2008Author Commented:
That did it. I reset them back up and good to go. Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.