?
Solved

Low speed on Cisco Router 1841 with SMC cable modem

Posted on 2012-09-20
8
Medium Priority
?
1,472 Views
Last Modified: 2012-10-03
We have Cisco router 1841
IOS  c1841-advipservicesk9-mz.124-25e.bin
Or c1841-advsecurityk9-mz.124-22.T4.bin
We connected this router to business Cable Modem SMCD3GN2-BIZ with speed up to 50Mb.
However our speed is in no more than 2 Mb. Though through any new Linksys or Netgear is 40Mb.
 We had a similar issue before with Comcast SMC older modem, and found that IOS c1841-advipservicesk9-mz.124-25e.bin on the router resolved this very weird problem. Now we tried several different IOS, but no result.

Did anyone else encounter this problem too?
Thank you for advance.
0
Comment
Question by:csinow
8 Comments
 
LVL 13

Assisted Solution

by:themrrobert
themrrobert earned 750 total points
ID: 38419920
Try the steps here: http://www.dslreports.com/faq/16583

It seems that this issue could be caused by a great many issues, including config files, ios version, and IP settings. I found several posts and sites with questions regarding Cisco 1841 slowness, but the link I posted here has the most relevant and useful information.
0
 

Author Comment

by:csinow
ID: 38419994
I'm posting more information.
This 1841 router worked in production environment in a different location with Comcast modem SMCD3G-CCR. Speed was 25Mb.
We use the same config  in 4 location. Cisco says regarding compatibilities with DOCSIS. This link: http://www.cisco.com/en/US/docs/cable/cmts/wideband/solution/guide/release_2.0/append.html.
I do not understand what exact IOS can be compatible. Preferable Advanced IP Services IOS.
0
 
LVL 13

Expert Comment

by:themrrobert
ID: 38420104
It sounds like maybe you have to change the duplex settings and possibly the even more complex settings.

Check for loops in your network and config, and follow through the steps I listed, that should help you.
0
Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

 

Author Comment

by:csinow
ID: 38420365
Even there is no network. Just modem, router, an laptop. All settings on interfaces are without a firewall. It is basic as possible. The same speed no more the 4Mb. i found IOS c1841-advipservicesk9-mz.124-25f. Speed a little bit increased.
0
 
LVL 12

Expert Comment

by:ryan80
ID: 38420484
Do you have any incrementing counters on any interfaces. I have used 1841 on connections over 100 mbps. My average packet size was about 800 bytes.
0
 

Author Comment

by:csinow
ID: 38420515
Here is router interfaces config:
interface FastEthernet0/0
 description OUTSIDE
 ip address 97.32.xx.xx 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description INSIDE
 ip address 10.20.20.2 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 speed 100
 full-duplex
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 97.32.ss.ss
!
ip http authentication local
ip http secure-server
ip nat inside source list 100 interface FastEthernet0/0 overload
0
 
LVL 3

Accepted Solution

by:
vipelite earned 750 total points
ID: 38457695
Can you post the command:

sh int fa0/0
sh int fa0/1

As well as what's the memory size on this router? or I/O maybe too low and I notice you're using the command ip virtual-reassembly could potential slow down your router.

But these are just speculations... what would help if you reproduce the problem and run commands such as:

sh processes CPU sorted | ex 0.00 to assure you're router isn't do anything funny.

Also, based on your isolation between netgear/lynksis hub switches which works fine.. could be a duplex issue since hub/switches use half-duplex may try half-duplex towards the modem. You never know it's worth a try! =p

Also, do you need to add any type of bandwidth on the interface facing modem? may want to look into this as well bandwidth 50000 under the interface. May require for the modem to communicate on the higher level protocols.

Post your results and let's see if we can narrow this down..
0
 

Author Closing Comment

by:csinow
ID: 38459104
Problem has been solved. We put WAN interface f0/0 with speed auto! Speed went up to 50Mb
0

Featured Post

Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Cable Modem Provisioning from DPoE compliant server  This Article is to support CMTS administrators to provide an overview of DOCSIS compliance configuration file, and to provision a cable modem located at customer place from a Back office serve…
Last month, the FCC voted to repeal Title II, the framework supporting net neutrality across all broadband ISPs. We sat down with Doug Walton, database administrator at Experts Exchange to gauge his opinion of what will happen next.
This video tutorial shows you the steps to go through to set up what I believe to be the best email app on the android platform to read Exchange mail.  Get the app on your phone: The first step is to make sure you have the Samsung Email app on your …
Watch the video to learn how one can deal with PST file corruption issue with an outstanding Kernel for Outlook PST Repair Tool easily. Using this tool, non-technical users can swiftly perform the repair process to restore their essential data witho…

593 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question