exchange server 2010 sp2 fail

Posted on 2012-09-20
Last Modified: 2013-01-30
Tried to upgrade to exchange server 2010 sp2 and after a reboot our exchange server was no longer on our server running 2008 r2. I can locate the files in the directory we installed to, but there isn't anyway to get it running. Under the start menu exchange server folder is completely gone as well. I can locate the mmc but it will not operate correctly either.  When i go into services all of the exchange services are disabled and when setting them to automatic start up I can not initialize them. They all fail to start with an error. We have tried re-installing but get an error saying it cannot locate original set up location or something to that effect. We then tried deleting the registry entries to maybe remove any trace of exchange, but that didnt work either. At this point we are really clueless as to where we need to go from here.

Please help!

Question by:robwes79
    LVL 13

    Expert Comment

    Try repairing with the original version of the software. (the old version of exchange).

    After you get the old version installed, then try the upgrade again, making extra effort to insure a proper install. (installing in the right mode, with the right version, minimal other programs running)

    I've had similar things happen, but not with exchange. This can happen if other programs are preventing a successful registry and start-menu install, perhaps the folder was not writeable or lost connectivity (if a remote or removable device, or even if its an installed device that had a driver failure).

    Another possibility is the install script failed out, but then it shouldn't have rebooted. Did you initiate the reboot yourself or was it part of the install script?

    Author Comment

    We tried installing from the original disk for exchange but that does not work either.
    LVL 63

    Accepted Solution

    I would suggest a call to Microsoft at this point, so that you can recover the server.
    Exchange service packs basically reinstall the product, but the configuration is stored in the domain.
    The registry hacking hasn't helped though, you may well be looking at stripping the data from the server, rebuilding the server and then doing a recver installation of Exchange. However getting Microsoft involved is your best option because if you attempt things like that and it doesn't work, you have significantly reduced your chances of a successful recovery.


    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Too many email signature changes to deal with?

    Are you constantly being asked to update your organization's email signatures? Do they take up too much of your time? Wouldn't you love to be able to manage all signatures from one central location, easily design them and deploy them quickly to users. Well, you can!

    Use these top 10 tips to master the art of email signature design. Create an email signature design that will easily wow recipients, promote your brand and highlight your professionalism.
    Check out this infographic on what you need to make a good email signature that will work perfectly for your organization.
    In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
    how to add IIS SMTP to handle application/Scanner relays into office 365.

    759 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    13 Experts available now in Live!

    Get 1:1 Help Now